[SOLVED] kernel panic - not syncing attempted to kill init

Discussion in 'Proxmox VE: Installation and configuration' started by emmanuel, Sep 15, 2018.

  1. emmanuel

    emmanuel New Member

    Joined:
    Dec 5, 2017
    Messages:
    19
    Likes Received:
    1
    I have a proxmox machine experiencing the issue stated above. I was wondering if there is anyway to restore proxmox, since I have formatted its thin volumes and have my files in there(/dev/mapper/storage), when I did an install on another hard drive I tried to mount the directory where my data is located from the old install to the new one, but even though activating the volume group via "vgchange -ay" it cannot activate the volume group. So if there is no way to fix the issue I was wondering if there is anyway for me to mount the old file system off to a new one so I can just grab my files from the old install?
     
  2. emmanuel

    emmanuel New Member

    Joined:
    Dec 5, 2017
    Messages:
    19
    Likes Received:
    1
    [​IMG] Inserting additional info since I cannot post a screenshot or access its log files, this is what I get when booting into Rescue Mode when creating a bootable drive for proxmox
     
  3. emmanuel

    emmanuel New Member

    Joined:
    Dec 5, 2017
    Messages:
    19
    Likes Received:
    1
    Ok so I manage to rectify this whole thing myself, while some of the data have been corrupted due to IO Errors but the important ones are all okay. So in order to help people in the future I will list in here the steps I did.

    1. Installed Ubuntu Bionic Beaver on a separate hard drive.
    Note: You can go the "Live" route, which is just booting operating system off your system memory, but since this is a long process of transferring files I need to install it on a hard drive to save changes like adding stuff in the fstab or crontab to mount the thin logical volumes from my hard drive where Proxmox is installed. This might be useful in case my server is restarted by accident.

    2. Install thin-provisionin-tools deb file found in here:
    https://ubuntu.pkgs.org/18.04/ubunt...visioning-tools_0.7.4-2ubuntu3_amd64.deb.html
    Note: I used the AMD64 version, as this is on a 64-bit operating system and processor. Issue the command "sudo dpkg -i <.deb_file>". In cases of errors during the dpkg install, issue the command "apt-get install -f" to get it to install by force.

    3. Then repair the thin volume by issuing "lvconvert --repair <volume_group>/<logical_volume>"

    4. Activate the volume group by typing in "vgchange -ay <volume_group>", usually the volume group is named "pve" when doing the proxmox installation by default on most if not all options.

    5. Since in my situation I had my root file system installed on an automated partitioning scheme by Proxmox on an 88GB partition in a 2TB hard drive, the remaining 1.7TB or so was allocated as a thin volume, I formatted that via fdisk utility so I can use that enormous space and set a different partition and named it "pve-storage" and mounted it off a "storage" directory on my root file system. That same partition I mounted on a "storage" directory in my Ubuntu file system to keep things uniform.

    6. Check mount point using "df -Th" to see if it is mounted.

    7. Plug in your flash drive or external hard drive and start transferring stuff using the mv, cp or rsync utility, I created a tmux session for this to keep it running in the background in case I get disconnected from the terminal by accident. I installed openssh-server on my Ubuntu machine so I can connect to it remotely via smartphone with juicessh installed so I can perform the transfer from there. Weird enough, my external hard drive cannot be detected on my Ubuntu machine but works fine on all our Windows machine, which I will find out but it is out of scope of the thread I'm posting here.

    Hopefully this helps someone out there in the future, thanks!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice