Keine Internet verbindung

dannyo

New Member
Feb 19, 2020
4
1
3
31
Hallo,

ich nutz das Mailgateway schon ein wenig länger nun wollt ich diese ein mal neben bei Neu und Sauber aufsetzen. Ich habe nun den Interessanten Fehler das das Mailgateway über meinen DNS die Namen auflösen kann allerdings kann ich dies weder erreichen noch pingen. Meinen Internen IP's kann ich ganz normal Pingen und auch erreichen sogar mein Gateway. Die anderen Maschinen in meinem LAN kommen ins Internet und können auch raus pingen. Das Ganze ist bei mir hinter eine OPNSense wobei ich dort mittlerweile alles nach aussen erlaube und es Funktioniert immer noch nicht.

Hat das PGM eine Firewall die ebenfalls noch aktiv ist?


Liebe Grüße
Dannyo
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,192
864
148
bitte mal folgende commandos testen:
* `ip a show` (da sollte die IP auftauchen, die configuriert ist)
* `ip route show` (da sollte default -route (ueber das gateway) stehen)
* `ping <GATEWAYIP>` (wobei <GATEWAYIP> durch die oben gelernte gateway ip ersetzt werden soll)
* `ping 8.8.8.8` (eine public ip pingen)
* `cat /etc/network/interfaces`

Hat das PGM eine Firewall die ebenfalls noch aktiv ist?
Nicht in der default install.

Ich hoffe das hilft!
 

dannyo

New Member
Feb 19, 2020
4
1
3
31
Hallo,

leider hat mir das auch nicht weiter geholfen aber ich werde mal meine Ergebnisse posten.

ip a show gibt die richtige IP und Subnetz aus
Bildschirmfoto 2020-02-19 um 16.18.51.png

ip route show gibt auch das richtige Gateway aus den 192.168.21.254 ist mein Gateway
Bildschirmfoto 2020-02-19 um 16.21.21.png

pingen des Gateways funktioniert einwandfrei
Bildschirmfoto 2020-02-19 um 16.22.14.png

ping des google DNS scheitert ich hab nach einer Zeit den Ping abgebrochen
Bildschirmfoto 2020-02-19 um 16.23.11.png

etc/network/interfaces Datei
Bildschirmfoto 2020-02-19 um 16.23.48.png

Zum Test hab ich das gleiche bei einer Maschine die im Selben Netz sitz probiert
/etc/network/interfaces
Bildschirmfoto 2020-02-19 um 16.24.41.png

dort funktioniert der Ping auf google
Bildschirmfoto 2020-02-19 um 16.24.18.png

anbei meine Firewall Regel noch die aber sowieso alles erlaubt
Bildschirmfoto 2020-02-19 um 16.25.44.png
 
Last edited:

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,192
864
148
* sieht soweit richtig aus und wenn das gateway pingbar ist wäre die erste Vermutung, dass es dort ein Problem gibt.
* falls auf dem PMG direkt eine firewall installiert sein sollte müssten die regeln mit `iptables -nvL` angezeigt werden
* alternativ fällt mir noch ein - auf was läuft das PMG? - wenn virtualisiert - ist vielleicht auf dem hypervisor eine firewall konfiguriert?
 

dannyo

New Member
Feb 19, 2020
4
1
3
31
Naja warum geht es den bei den anderen Maschinen dann :confused:

eiso laut iptabels ist alles accept

Die PMG läuft virtuell auf einen PVE das witzige ist ich habe es dort sowohl als lxc probiert wie auch als VM bei beiden habe ich das selbe problem. Bei der PVE war einmal test weise die firewall aufgedreht ist aber wieder abgedreht steht auch alles auf accept.
 

dannyo

New Member
Feb 19, 2020
4
1
3
31
Hat sich erledigt hab einfach die IP Adresse einmal auf eine andere gesetzt und wieder zurück und zack es geht wieder :cool:
 
  • Like
Reactions: Stoiko Ivanov

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,192
864
148
Schön, dass es funktioniert.

Ich würde in der Situation nochmal schauen, ob die IP nicht möglicherweise 2 mal vergeben ist (einfach pmg mal abdrehen - und wenn es aus ist die ip pingen)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!