[SOLVED] iPXE Boot, KVM, Ubuntu 18, USG - Hangs after pxelinux.0

Seed

Active Member
Oct 18, 2019
98
61
38
124
Hello,

I have a new VLAN 8. This network supports network boot and tftp settings. Requests that are network booted from a KVM host that is tagged on VLAN 8 get the right IP from DHCP, then goes to fetch the pxelinux.0 from my nas. This works as well as the file is downloaded, but then it just sits there. I can't tell where it broke and the logs don't help much. It says it was fetched in the logs and an "ok" in the UI. I'm using the netboot for both debian buster and ubuntu bionic and they both exhibit the same behavior.

I also noticed then when it gets the IP from the USG it's active for a quick second, which I guess makes sense as it did what it had to do. Is this a UI thing where maybe it's doing something that I can't see for some reason after it pulled the config? I should see the menu right after it loads. VM CPU is chugging pretty good still.
 

Attachments

  • Screen Shot 2019-11-16 at 6.22.50 PM.png
    Screen Shot 2019-11-16 at 6.22.50 PM.png
    41.5 KB · Views: 38
Last edited:
The symlinks in the netboot configs got all jacked up when I copied them from my mac to the nas. Doing so with cli to the nas solved those issues
 
Hi can you walk me through how to set this up. I’ve been trying to get a NetBoot going for a windows VM that I have running in each of my kids room.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!