I keep getting a zfs error, but i dont use zfs

fxandrei

Renowned Member
Jan 10, 2013
146
12
83
So a have a test cluster, with 3 nodes.
I keep receiving this error from one node:

ZFS has detected that a device was removed.

impact: Fault tolerance of the pool may be compromised.
eid: 1
class: statechange
state: UNAVAIL
host: int2
time: 2023-08-07 19:53:42+0300
vpath: /dev/disk/by-id/dm-uuid-LVM-qLsNb01KC9eWYHna3QBkXITHxI0ZyPXAsQHHzpqIgEYuG2yeatiy7eV5PATw79rH
vguid: 0x045B1A449BE72937
devid: dm-uuid-LVM-qLsNb01KC9eWYHna3QBkXITHxI0ZyPXAsQHHzpqIgEYuG2yeatiy7eV5PATw79rH
pool: rpool (0xA11422AA14EDD8C3)


The thing is that on this node (int2) i dont use zfs.
I have no clue where this is comming from.

Any ideeas ?
 
Hi,
did you use ZFS in the past on this node? What does zpool status -v show?
 
So that cmd returns:

root@int2:~# zpool status -v
no pools available


And i only have these drives:
1691492397398.png

I did not use zfs on this server.


By the way. Im talking about proxmox, not PBS (i just saw i posted in the PBS section).
 
Last edited:
Was the drive ever previously used for ZFS and then repurposed for Ceph? Maybe there is still some left-over signature which confuses the ZFS event daemon?
 
No i did not use zfs at all.
And the device the error is indeed used, but its a ceph cluster.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!