How to disable TLS 1.0 web gui Proxmox Mail Gateway

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
2,661
290
83
AFAIR this is not 'easily' configurable - please open a feature-request at https://bugzilla.proxmox.com should you need it.

Currently the workaround would involve patching `/usr/share/perl5/PMG/Service/pmgproxy.pm` (search for 'sslv3 => 0,' and add a 'tlsv1 =>0,' below).
 
  • Like
Reactions: Eric Barreto

Eric Barreto

New Member
Feb 10, 2019
6
0
1
26
AFAIR this is not 'easily' configurable - please open a feature-request at https://bugzilla.proxmox.com should you need it.

Currently the workaround would involve patching `/usr/share/perl5/PMG/Service/pmgproxy.pm` (search for 'sslv3 => 0,' and add a 'tlsv1 =>0,' below).
@Stoiko Ivanov

Thanks for the help, the outline solution seems to work for me, according to sslscan. I tried to disable tlsv1.1 by typing in this syntax: tlsv11, but it did not work.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!