[SOLVED] How i can remove directory-entry from gui?

fireon

Famous Member
Oct 25, 2010
3,094
197
83
Austria/Graz
iteas.at
Hello all,

i've tested something with an HDD. I've created in the GUI an EXT4 disk and added this automatically to the storage's. So i would delete it. But there is no button for removing directories. On CMD i also nothing found about. Only the file "/etc/pve/.rrd" there is this entry, but this file is not variable.

Screenshot attached.

Thanks :)
 

Attachments

fireon

Famous Member
Oct 25, 2010
3,094
197
83
Austria/Graz
iteas.at
I didn't understand. I searched for:
Code:
grep -R -i /mnt/pve/testdir /etc/
/etc/systemd/system/multi-user.target.wants/mnt-pve-testdir.mount:Where=/mnt/pve/testdir
/etc/systemd/system/mnt-pve-testdir.mount:Where=/mnt/pve/testdir
Also in the pve-doc's.
I disabled the service and unount the target:
Code:
systemctl disable mnt-pve-testdir.mount
umount /mnt/pve/testdir
I also unpluged the hdd from the server but nothing, the entry didn't go away.

Thanks :)
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
16,529
328
103
Austria
www.proxmox.com
Just verified the code, but what you describe is not really possible - at least I can't see how that happens. Maybe it is a browser problem? Already tried to clear the browser cache, or used another browser?
 

fireon

Famous Member
Oct 25, 2010
3,094
197
83
Austria/Graz
iteas.at
Hi Dietmar,

Just verified the code, but what you describe is not really possible - at least I can't see how that happens. Maybe it is a browser problem? Already tried to clear the browser cache, or used another browser?
What should i say... it's there. Removed the firefoxconfig, and tested with fresh chromium. Same problem. Proxmox will mount the disk. But the disk was removed. No enry in the file "/etc/pve/.rrd".

Nothing:
Code:
grep -R -i /mnt/pve/testdir /etc/
grep: /etc/systemd/system/multi-user.target.wants/snmpd.service: Datei oder Verzeichnis nicht gefunden
grep: /etc/systemd/system/multi-user.target.wants/pve-manager.service: Datei oder Verzeichnis nicht gefunden
/etc/systemd/system/mnt-pve-testdir.mount:Where=/mnt/pve/testdir
grep: /etc/ssl/certs/startcom-ca2.pem: Datei oder Verzeichnis nicht gefunden
grep: /etc/fonts/conf.d/70-no-bitmaps.conf: Datei oder Verzeichnis nicht gefunden
 

Gizmo_RA2

New Member
Dec 27, 2018
2
1
1
36
I have the same problem, I have removed the drive, and the mount point, pvesm remove <directory>, vgchange -a n <directory>, vgremove <directory>, rebooted the server, still shows up under directories in the web gui
 

fireon

Famous Member
Oct 25, 2010
3,094
197
83
Austria/Graz
iteas.at
I have the same problem, I have removed the drive, and the mount point, pvesm remove <directory>, vgchange -a n <directory>, vgremove <directory>, rebooted the server, still shows up under directories in the web gui
Thanks a lot for the information, so i'am not alone with :eek::)
 

fireon

Famous Member
Oct 25, 2010
3,094
197
83
Austria/Graz
iteas.at
did you delete the systemd mount unit file?
/etc/systemd/system/mnt-pve-testdir.mount
Thanks a lot, this is the trick. After deleted the file and reload systemd the entry was gone. So maybe something is missing in that process?
 

davidinterian

New Member
Sep 21, 2019
1
0
1
30
i follow your post

first:

Code:
systemctl disable mnt-pve-testdir.mount
umount /mnt/pve/testdir
Then

Code:
nano /proc/mounts
Exit with Control X

Then

Code:
rm /etc/systemd/system/mnt-pve-testdir.mount
finally,

Code:
reboot
Thank You all!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!