Hostname of Node changed - How to revert to normal

alfubo

New Member
Mar 15, 2022
1
0
1
24
Hi
I have a question about the Hostname and nodes of Proxmox.
I accidently changed the node name of my Proxmox with the command: hostname <name>.
Now i have a problem... Proxmox is using this new name thats not correct as Hostname. It also created a node named like this:
1648646285279.png
In my Webgui its represented as Vserver.
1648646307295.png
This is my hosts file.
View attachment 35596

I also have, with the command: hostnamectl, two diffrent hostnames.
Static hostname:
Vserver1
transient Hostname: Vserver1.somedomain

Can someone maybe point me to the source of the problem, without having to reinstall the node? I have runnibg VMs with active services on this node.

Also in the Shell log i see that if i want to connect to the proxmox shell or backup/restore a VM, it wants to connect to the host "apply", it does the job and the backup or restore works. Apply was one of the accidently created hostname.
1648646943558.png
But if Proxmox is trying to run tasks over this Node, i cant display any status about the active task its running, its marked also as unknown in the status tab(double click the log entry->Status).

Thanks for the help
Alfubo
 

Attachments

  • 1648646280565.png
    1648646280565.png
    2.6 KB · Views: 2
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!