High IO Delay

Jul 2, 2020
4
0
1
37
So I'm having a big issue with Proxmox VE 6.2. I have an HPDL325 with 4xKingston DC450R 2TB on ZFS with an impossible 70% IO Delay.

I'm attaching a screenshot of Proxmox VW restoring a Backup from an NFS share, but it's the same for every write intensive operation on disk.

I really don't know where to start the troubleshooting so any help would be great.

Thanks in advance.
 

Attachments

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
4,258
665
133
according to the specs these are SSDs specifically optimized for read-centric applications - they might just not performe well when facing write-intensive operations?
 
was the problem always there or when did it start to appear ?
did you change something before that ?
is it your first rodeo with zfs ?

I'm attaching a screenshot of Proxmox VW restoring a Backup from an NFS share
but the IO delay could also come from the NFS part isn't it ?

but it's the same for every write intensive operation on disk.
can you give us an example with actual numbers pl
 
Jul 2, 2020
4
0
1
37
according to the specs these are SSDs specifically optimized for read-centric applications - they might just not performe well when facing write-intensive operations?

Thank you,

I understand the difference between them, but the thing is that is impossible to use them, if I use them on Windows with Software RAID they work normally.

I haven't replaced any disk, this is a brand new server with brand new disks, I also have the exact same server but with Kingston DC500R working normally.


was the problem always there or when did it start to appear ?
did you change something before that ?
is it your first rodeo with zfs ?



but the IO delay could also come from the NFS part isn't it ?



can you give us an example with actual numbers pl
Actually my second ZFS Proxmox install, the first one is running great.

What would a good test be?

I get high IO delay also when full cloning a VM, so it's not the NFS.
 

H4R0

Active Member
Apr 5, 2020
228
32
28
28
What kind of software applications are running on the server ?

Can you run "zpool iostat 30" for 6 minutes and then abort with ctrl+c and post the output.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!