Hetzner Netzwerkconfig

Meso

New Member
Aug 1, 2020
9
0
1
23
Guten Abend,

kennt sich wer mit der Hetzner Netzwerkconfig für Proxmox aus?
Meine VM bekommt einfach keine Internetverbindung

Code:
# /etc/network/interfaces
### Hetzner Online GmbH - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto enp4s0
iface enp4s0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  pointopoint 176.9.76.161
  gateway 176.9.76.161

# fuer Einzel-IPs
auto vmbr0
iface vmbr0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  bridge_ports none
  bridge_stp off
  bridge_fd 0
  up ip route add 176.9.76.201/32 dev vmbr0

# fuer ein Subnet
auto vmbr1
iface vmbr1 inet static
  address 10.10.10.10
  netmask 255.255.255.0
  bridge_ports none
  bridge_stp off
  bridge_fd 0
Code:
# /etc/network/interfaces
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto ens18
iface eth0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  pointopoint 176.9.76.193
  gateway 176.9.76.193
 

Meso

New Member
Aug 1, 2020
9
0
1
23
Ja, das habe ich auch so ausgeführt, leider kein erfolg.

die IP pingt, leitet wohl aber nicht an die VM weiter bzw. die VM bekommt einfach kein Internet.



Code:
# /etc/network/interfaces
### Hetzner Online GmbH - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto enp4s0
iface enp4s0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  pointopoint 176.9.76.161
  gateway 176.9.76.161


# fuer Einzel-IPs
auto vmbr0
iface vmbr0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  bridge_ports none
  bridge_stp off
  bridge_fd 0
  up ip route add 176.9.76.*/32 dev vmbr0
Code:
source /etx/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto ens18
iface ens18 inet static
        address 176.9.76.*
        netmask 255.255.255.255
        pointoopint 176.9.76.*
        gateway 176.9.76.*
        nameserver 8.8.8.8
 
Last edited:
Jan 21, 2017
322
45
33
Berlin
Ja, das habe ich auch so ausgeführt, leider kein erfolg.

die IP pingt, leitet wohl aber nicht an die VM weiter bzw. die VM bekommt einfach kein Internet.



Code:
# /etc/network/interfaces
### Hetzner Online GmbH - installimage
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto enp4s0
iface enp4s0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  pointopoint 176.9.76.161
  gateway 176.9.76.161


# fuer Einzel-IPs
auto vmbr0
iface vmbr0 inet static
  address 176.9.76.*
  netmask 255.255.255.255
  bridge_ports none
  bridge_stp off
  bridge_fd 0
  up ip route add 176.9.76.*/32 dev vmbr0
Code:
source /etx/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto ens18
iface ens18 inet static
        address 176.9.76.*
        netmask 255.255.255.255
        pointoopint 176.9.76.*
        gateway 176.9.76.*
        nameserver 8.8.8.8

bridge_ports none

Port Brücken setzen, IP Konfig an der NIC entfernen und auf Manual setzen. Entsprechend die Host ip Konfig auf die erste Brücke legen.
IP forwarding in der sysctl aktivieren.
Falls eine Firewall verwendet wird, diese auch entsprechend für ip forwarding konfigurieren.
 

Meso

New Member
Aug 1, 2020
9
0
1
23
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto ens18
iface ens18 inet static
        address 176.9.76.*
        netmask 255.255.255.255
        pointopoint 176.9.76.*
        gateway 176.9.76.*
und in der /etc/resolv.conf den Nameserver von Cloudflare eingefügt, so funktioniert das ganze!

Danke für die Hilfe :)
 
Jan 21, 2017
322
45
33
Berlin
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto ens18
iface ens18 inet static
        address 176.9.76.*
        netmask 255.255.255.255
        pointopoint 176.9.76.*
        gateway 176.9.76.*
und in der /etc/resolv.conf den Nameserver von Cloudflare eingefügt, so funktioniert das ganze!

Danke für die Hilfe :)
Nimm die DNS Server von Hetzner. Die reagieren schneller, auch wenn cloudflare schnell ist.
 

ssldn

New Member
Jul 13, 2020
8
1
3
44
Hat es denn für exakt diesen Setup (Host nur routed anzubinden, 3 IPs, Keine zusätzlichen MACs, dann intern bridge zu den VMs damit die auch per RDP erreichbar werden (denke auch noch über ein Vlan nach)) noch eine verständlichere Beschreibung, zusammenhängend und so...? Diese zwei Themen Netzwerk sowie BIOS/ UEFI habe ich in den letzten 14 Jahren Linux sträflich vernachlässigt.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!