[SOLVED] HELP Web Interface OFFLINE due PCI VM NETWORK CONTROLLER on auto-startup!

Redicat

Member
May 22, 2021
65
4
8
23
HELP Web Interface OFFLINE due PCI VM NETWORK CONTROLLER on auto-startup!

I tried installing Pfsense and adding my 2.5Gbit Nic to it but now i cannot acces the web ui since i started the VM and it booted the web ui offline due probably noob mistake?

Auto-startup/startup on boot is ON :/
 

datschlatscher

Active Member
Staff member
Mar 14, 2022
113
39
28
Depending on your setup you just have to find a way to access it without the web interface/SSH and change the VM config file in /etc/pve/qemu-server/<vmid>.conf

In that file either turn off start-on-boot by removing the entry `onboot: 1`
or remove the line adding the PCI device which should look something like this hostpci0: 0000:05:00.0.
 

Redicat

Member
May 22, 2021
65
4
8
23
Depending on your setup you just have to find a way to access it without the web interface/SSH and change the VM config file in /etc/pve/qemu-server/<vmid>.conf

In that file either turn off start-on-boot by removing the entry `onboot: 1`
or remove the line adding the PCI device which should look something like this hostpci0: 0000:05:00.0.
I don't have SSH installed. AT ALL.
 

Redicat

Member
May 22, 2021
65
4
8
23
Depending on your setup you just have to find a way to access it without the web interface/SSH and change the VM config file in /etc/pve/qemu-server/<vmid>.conf

In that file either turn off start-on-boot by removing the entry `onboot: 1`
or remove the line adding the PCI device which should look something like this hostpci0: 0000:05:00.0.
How do you SSH into it? bc i have not configured anything at all i never use SSH
 

datschlatscher

Active Member
Staff member
Mar 14, 2022
113
39
28
How do you SSH into it? bc i have not configured anything at all i never use SSH
Your NIC is passed through to the VM every time on boot. Therefore, making it unavailable for your Proxmox node. With no network, you also cannot connect via SSH.

I'm afraid I worded my answer above a bit confusingly. But you do not connect over SSH, you will need to find an offline way of accessing it. The most simple way would be at the site of the server, with a mouse and keyboard.
 

Redicat

Member
May 22, 2021
65
4
8
23
Your NIC is passed through to the VM every time on boot. Therefore, making it unavailable for your Proxmox node. With no network, you also cannot connect via SSH.

I'm afraid I worded my answer above a bit confusingly. But you do not connect over SSH, you will need to find an offline way of accessing it. The most simple way would be at the site of the server, with a mouse and keyboard.
I disabled the gui on the monitor..

Is it possible to run eg Linux/Herin'sBOOT-PE to change the configuration files of the VM?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!