GPU Passthrough and Linux guest freeze.

LuchS

New Member
Aug 29, 2021
10
4
3
37
I have Clevo N957TC Laptop (i7 8700, 16Gb RAM, GTX1660ti max-q). I successfully install to this configuration ProxMox 7.1-12 and done GPU passthrought my NVIDIA video card. When i am using Windows as a guest - everything ok. This virtual machine works stable and well. When i do the same with Debian 11 as a guest with nouveau video driver, with the same setting of virtual machine - the Operation System is frozen. And Big problem to install proprietary driver for a NVIDIA video card, because i got the black screen. I tried the different - used the from NVIDIA site, used from repository - always black screen without cursor. Driver of nouveau works. When i add to GRUB at my virtual machine to line with GRUB_CMDLINE_LINUX_DEFAULT= parameter nouveau.noaccel=1, system become stable, but i need video acceleration for my software, i need OpenGL.

I tried Manjaro Linux, Garuda Linux, Deepin Linux, LinuxMint, Fedora 35 Gnome. Usually cursor of the mouse usually working and system freeze. This is not in constant time, sometimes it takes 1 hour or more, sometimes 1 min.

Console of my Debian 11 virtual machine :
dmesg | grep -i "error\|warn\|fail"
[ 597.275393] WARNING: ***: 3 PID: 69 at drivers/gpu/drm/nouveau/nvkm/engine/fifo/gk104.c:447 gk104_fifo_recover_engn+0x20a/0x220 [nouveau]
[ 597.275445] ghash_clmulni_intel drm_kms_helper virtio_net virtio_scsi net_failover failover ahci cec libahci aesni_intel libaes crypto_simd drm xhci_pci cryptd xhci_hcd glue_helper uhci_hcd ehci_pci ehci_hcd psmouse i2c_i801 libata i2c_smbus scsi_mod usbcore virtio_pci virtio_ring virtio lpc_ich usb_common button

Virtual machine settings with Debian 11:
agent: 1
args: -cpu 'host,+kvm_pv_unhalt,+kvm_pv_eoi,hv_vendor_id=willitwork,kvm=off' -object 'input-linux,id=kbd,evdev=/dev/input/event4,grab_all=on,repon,repeat=on'
balloon: 0
bios: ovmf
boot: order=scsi0;ide0
cores: 6
cpu: host,hidden=1,flags=+pcid
efidisk0: local-lvm:vm-901-disk-0,size=4M
hostpci0: 01:00,pcie=1,x-vga=on
ide0: none,media=cdrom
machine: pc-q35-5.1
memory: 10240
name: DebianVM
net0: virtio=5E:F2:F1:EA:DD:56,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: local-lvm:vm-901-disk-1,size=80G
scsihw: virtio-scsi-single
smbios1: uuid=2acf86a2-2cab-4581-8fd1-0bfe0a41d460
sockets: 1
usb0: host=1-4,usb3=1
usb1: host=1-3,usb3=1
vga: none
vmgenid: 3e09a013-55af-4d86-88f7-3148f3dda8b5

grub at the host:
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"

/etc/modprobe.d/blacklist.conf at the host:
blacklist radeon
blacklist nouveau
blacklist nvidia
 
Last edited:

LuchS

New Member
Aug 29, 2021
10
4
3
37
Specific Nvidia chips with Nouveau may give random system lockups and more commonly throw many kernel messages, seen with dmesg. Try adding the nouveau.noaccel=1 kernel parameter. See Fedora:Common kernel problems#Systems with nVidia adapters using the nouveau driver lock up randomly for more information.

As an alternative you can also use the QT_XCB_FORCE_SOFTWARE_OPENGL=1 environment variable to disable OpenGL acceleration in Qt applications.

https://wiki.archlinux.org/title/nouveau

Looks like i have problems with OpenGL acceleration in Qt applications. Is it possible to fix this?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!