[SOLVED] Ethernet port not functioning after install ...


New Member
Jan 5, 2022
Hi all,
I am a relative newbie to virtualization (having dabbled with VirtualBox) and just wanted to try out a type 1 hypervisor.
For this purpose, I put together a "mini-server" (GIGABYTE BRIX, AMD Ryzen 7, 32 GB RAM, 2 TB SSD), downloaded the latest version of Proxmox and put the image on a USB stick.

The install went fine ... it connected to the local DHCP server (my Fritz!Box) and got an IP4 address assigned - so up to this point, the ethernet port is definitely working.

After installing, I reboot the server and it boots up. I can log in at the CLI as root.

"ip a" shows me the following interfaces:

1: lo: LOOPBACK (state UNKNOWN)
2: enp2s0: BROADCAST, MULTICAST (state DOWN)

From the MAC address, I can see that it used enp2s0 during the install (it showed on my Fritz!Box with the expected IP address shown on the installation screen).

Since the ethernet port is not active, I can not easily extract log files (since I can SSH to the server and the server has no connection to the outside world).

The daemon.log shows some failed task (e.g. "ifupdown2-pre-service: Main process exited, code=exited, status =1/FAILURE" or "Dependency failed for Network initialization.").

This is now where I am lost. I did search the forum, but did not find any post that seems to fit my issue.

So my questions are:
1.) Is there anything that I am obviously doing wrong?
2.) What else could I try to get the ethernet port to work?

Any help would be appreciated.

Last edited:

So my questions are:
1.) Is there anything that I am obviously doing wrong?
2.) What else could I try to get the ethernet port to work?

Could you please post the output of the below commands from your Proxmox VE host:

ip a
cat /etc/network/interfaces
First of all, thank you for your help!
Luckily, I could use my smartphone to do a basic OCR (so I don't have to retype everything)...

I.) Output of ip a:

root@pve:~# ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000

     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

     inet scope host lo

        valid_lft forever preferred_lft forever

     inet6 ::1/128 scope host

        valid_lft forever preferred_lft forever

2: enp2sO: ‹BROADCAST,MULTICAST› mtu 1500 qdisc noop state DOWN group default qlen 1000

     link/ether de:5e:d3:68:34:bd brd ff:ff:ff:ff:ff:ff

3: Wlo1: <BROADCAST MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000

     link/ether f4:b3:01:69:53:b1 brd ff:ff:ff:ff:ff:ff

     altname wlp1s0
II.) Output of cat /etc/network/interfaces (I xxx'd part of the IP addresses):
root@pve:"# cat /etc/network/interfaces

auto l0

iface lo inet loopback


iface enp2s0 inet manual


auto vmbr0

iface vmbr0 inet static



     bridge-ports enp2s0

     bridge-stp off

     bridge-fd 0


Iface wlo1 inet manual
III.) Output of lspci | grep 'Ethernet':

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd RTL8125 2.5GbE Controller (rev 05)
Last edited:
Didn't had this problem by myself, but saw a video about it. Search for "Proxmox AMD Kernel Bug 5.13.19-2 - HM90" on YT. It's german, but hopefully can help you anyway.

He mentions running dhclient enp2s0 (in your case) on the host console to get a ip. Check with ip a again afterwards.

Hope this helps.

PS.: Instead of downgrading and holding the old kernel, you could also install the upcoming 5.15 kernel: https://forum.proxmox.com/threads/opt-in-linux-kernel-5-15-for-proxmox-ve-7-x-available.100936
  • Like
Reactions: carlituxman

Hi all,
turns out that this post had some very interesting information ... I did not try all the script stuff, but found the instruction to use
ip link set enp0s up
which ended up working for me.
After that, I was able to upgrade to kernel 5.15 and right now (keeping my fingers crossed), everything seems to be working OK :)

Thanks again to everyone for their help / input ...
I have a Broadcom NIC and I've tried everything I can find, still no joy. Anyone else have the "BCM57412 NetXtreme-E 10Gb RDMA Ethernet Controller"?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!