[SOLVED] Error when Apply Configuration in network

ddj

New Member
Nov 23, 2021
10
2
3
36
When I use the "Apply Configuration" button in the network section I get this message:

command 'ifreload -a' failed: exit code 1

Anyone can help?
 

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
1,762
192
83
Could you run that command on the command line and provide its output?
 

ddj

New Member
Nov 23, 2021
10
2
3
36
root@pve1:~# ifreload -a
error: vmbr0: cmd '/bin/ip route add default via 10.0.0.10 proto kernel dev vmbr0 onlink' failed: returned 2 (Error: Nexthop has invalid gateway.


I am sorry if the problem is obvious to be solved, I am a newbie.
 
Last edited:

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
1,762
192
83
Please provide the current network configuration (/etc/network/interfaces) as well as the new one (/etc/network/interfaces.new)
 

ddj

New Member
Nov 23, 2021
10
2
3
36
Network config (/etc/network/interfaces):

1637672389726.png

interfaces.new is empty.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!