Error Preparing initrd: Bad Buffer Size on fresh install


New Member
Jun 28, 2023
I'm running a dell r720xd with 12 4tb drives in the front and 2 256gb SSDs in the back. I installed Proxmox in ZFS raid 1 on the SSDs and when I boot I get the error "Error Preparing initrd: Bad Buffer Size." I updated all bios, firmware and put my raid card into I.T mode etc. I also can only boot into Proxmox via UEFI bios but still get the error. I tried boot from regular bios and it won't see my boot drive when I change the bios to boot non UEFI. I'm surprised I was able to make it this far as I'm a noob when it comes to enterprise server gear however I'm now stuck and any help would be much appreciated. I should mention that the main SSD that I installed Proxmox on had data on it and I'm not sure if when you install proxmox it auto formats and wipes the drive.


  • Proxmox Error Preparing initrd Bad Buffer Size.jpg
    Proxmox Error Preparing initrd Bad Buffer Size.jpg
    39.1 KB · Views: 5


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!