[SOLVED] Error of node name after Hostname Changed

semutmikro

New Member
Feb 5, 2021
28
3
3
32
Screenshot 2022-02-21 105844.png how do i remove with yellow circle ?
i have changed my host name of pve in this file /etc/hosts and /etc/hostname and the i reboot the pve node the config was succeeded but it showing the old name of hostname pve,
 

fiona

Proxmox Staff Member
Staff member
Aug 1, 2019
2,452
491
88
Hi,
please check /etc/pve/nodes, move relevant configuration files to the new node's directory and then remove the old node's directory.
 
  • Like
Reactions: semutmikro

semutmikro

New Member
Feb 5, 2021
28
3
3
32
Hi,
please check /etc/pve/nodes, move relevant configuration files to the new node's directory and then remove the old node's directory.
thanks for your help, it's solved, do i need moving the ssl file .pem and .key ?
 

fiona

Proxmox Staff Member
Staff member
Aug 1, 2019
2,452
491
88
These should be regenerated automatically. If they are not there for the renamed node, try running pvecm updatecerts on that node.
 
  • Like
Reactions: semutmikro

semutmikro

New Member
Feb 5, 2021
28
3
3
32
These should be regenerated automatically. If they are not there for the renamed node, try running pvecm updatecerts on that node.
thank again for the replay, yes it is regenerated, thanks for your help Fabian_E
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!