Error creating new container

JDISWT

New Member
Jun 30, 2020
1
0
1
36
I have a problem when creating a new container with Debian 10.2

The following error appears
Detected container architecture: amd64
TASK ERROR: unsupported debian version '10.2'
I already modified file Debian.pm ( /usr/share/perl5/PVE/LXC/Setup/Debian.pm ) with this content :
sub new {
my ($class, $conf, $rootdir) = @_;

my $version = PVE::Tools::file_read_firstline("$rootdir/etc/debian_version");

die "unable to read version info\n" if !defined($version);

# translate testing version names
$version = 9.1 if $version eq 'stretch/sid';
$version = 10 if $version eq 'buster/sid';
$version = 10 if $version eq '10.2';

die "unable to parse version info '$version'\n"
if $version !~ m/^(\d+(\.\d+)?)(\.\d+)?/;

$version = $1;

die "unsupported Debian version '$version'\n"
if !($version >= 4 && $version <= 11);

my $self = { conf => $conf, rootdir => $rootdir, version => $version };

$conf->{ostype} = "debian";

return bless $self, $class;
}
As you can see the error message doesn't corresponds to the one describe in the Perl file. I don't know how to force the file update.
Is it possible that another file is used?

I'm running Proxmox 5.2 :
Code:
root@sd-142904:~# pveversion -v
proxmox-ve: 5.2-2 (running kernel: 4.15.18-4-pve)
pve-manager: 5.2-8 (running version: 5.2-8/fdf39912)
pve-kernel-4.15: 5.2-7
pve-kernel-4.15.18-4-pve: 4.15.18-23
pve-kernel-4.15.18-2-pve: 4.15.18-21
corosync: 2.4.2-pve5
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.0-8
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-38
libpve-guest-common-perl: 2.0-17
libpve-http-server-perl: 2.0-10
libpve-storage-perl: 5.0-25
libqb0: 1.0.1-1
lvm2: 2.02.168-pve6
lxc-pve: 3.0.2+pve1-1
lxcfs: 3.0.0-1
novnc-pve: 1.0.0-2
proxmox-widget-toolkit: 1.0-19
pve-cluster: 5.0-30
pve-container: 2.0-26
pve-docs: 5.2-8
pve-firewall: 3.0-14
pve-firmware: 2.0-5
pve-ha-manager: 2.0-5
pve-i18n: 1.0-6
pve-libspice-server1: 0.12.8-3
pve-qemu-kvm: 2.11.2-1
pve-xtermjs: 1.0-5
qemu-server: 5.0-33
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
Do I need to restart some service after updating the file?

I already did this operation one another host with success, but I can't remember if I did something particular.

Thanks
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
2,876
453
103
South Tyrol/Italy
shop.maurer-it.com
Hi,
I'm running Proxmox 5.2 :
5.2 is EOL and isn't supported anymore, for running newer guest CTs, getting security and other bug fixes upgrade at least to 5.4 ASAP - but also note that the 5.4 will go EOL at the end of July!
Ensure you have valid Proxmox VE repository you can access setup https://pve.proxmox.com/wiki/Package_Repositories

After you upgraded to 5.4 please make plan an upgrade to latest 6.x soon. https://pve.proxmox.com/wiki/Upgrade_from_5.x_to_6.0
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,353
546
133
I'm running Proxmox 5.2 :
thats the issue, you run a totally outdated version.

just update to latest 5.4 or even better, to the current release 6.2.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!