[SOLVED] error after using SDN

daruom13

Member
Aug 1, 2020
31
2
8
35
Hello,

I finally decided to try the SDN functionality.
I managed to deploy my vnet with its VxLAN zone.

On the other hand, I have an error after the deployment, even if everything seems to work.
erreur ifreload.PNG


The problem also occurs when I apply a modification in the network part after adding a bridge
erreur ifreload 2.PNG

I have reinstalled the servers several times, but still have the same problem.
Anyone have a solution?
Thank.
 

spirit

Famous Member
Apr 2, 2010
5,782
676
133
www.odiso.com
can you send your /etc/network/interfaces config ?

and output of "ifreload -a -d" ?

do you really need to use dhcp ? (as you use vxlan anyway, you need static ip address for vxlan tunnel)
 

daruom13

Member
Aug 1, 2020
31
2
8
35
can you send your /etc/network/interfaces config ?

and output of "ifreload -a -d" ?

do you really need to use dhcp ? (as you use vxlan anyway, you need static ip address for vxlan tunnel)
The only interface that uses DHCP is vmbr0 (bridge eno1).
This is the basic configuration during installation at OVH.
I can put it in static if necessary.

more info, I ran the command "ifquery -a -c", I don't know if this is normal, but there is an error on eth0. However, I have no interface with his name.
 

Attachments

  • interfaces.txt
    892 bytes · Views: 5
  • ifreload.txt
    18.1 KB · Views: 6
  • ifquery.txt
    1.9 KB · Views: 5

spirit

Famous Member
Apr 2, 2010
5,782
676
133
www.odiso.com
This eth0 is very strange, the problem is really from this interface. (with dhcp client try to renew with eth0 as argument)

do you have any eth0 defined in /etc/network/interfaces.d/* ?

(remove dhcp should fix it, but I really don't known from where is coming this eth0)
 

daruom13

Member
Aug 1, 2020
31
2
8
35
Cet eth0 est très étrange, le problème vient vraiment de cette interface. (avec le client DHCP, essayez de renouveler avec eth0 comme argument)

avez-vous des eth0 définis dans /etc/network/interfaces.d/*?

(supprimer dhcp devrait le réparer, mais je ne sais vraiment pas d'où vient cet eth0)
oui, il y a bien un eth0 dans /etc/network/interfaces.d/50-cloud-init.
Code:
 root @ pve-gra-prod01: ~ # cat /etc/network/interfaces.d/50-cloud-init
# Ce fichier est généré à partir des informations fournies par la source de données. Changements
# ne persistera pas lors du redémarrage d'une instance. Pour désactiver cloud-init
# capacités de configuration réseau, écrire un fichier
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg avec ce qui suit:
# réseau: {config: disabled}
auto lo
bouclage iface lo inet
    DNS-nameservers XXX.XXX.XXX.XXX

auto eth0
iface eth0 inet dhcp
    mtu 1500

Par contre, j'ai regardé sur mon serveur de production, le fichier est également présent (j'avais installé SDN mais pas utilisé), et je ne rencontre pas cette erreur.

De plus, même sur le serveur de test, je n'avais aucun problème avant d'utiliser SDN.

Je peux réinstaller l'un des serveurs si nécessaire pour voir si le fichier est le fichier par défaut.

Pour DHCP, je n'en ai pas installé. Proxmox en lance-t-il un par défaut? Si oui, comment le désactiver (j'ai mis l'interface en statique, je ne sais pas si cela suffit)?

Merci.
 
Last edited:

spirit

Famous Member
Apr 2, 2010
5,782
676
133
www.odiso.com
Why do you have a /etc/network/interfaces.d/50-cloud-init file on your proxmox host ????

cloud-init is used inside the vms, but not on host.

just remove this /etc/network/interfaces.d/50-cloud-init (and check that cloud-init package is not installed)
 
  • Like
Reactions: daruom13

daruom13

Member
Aug 1, 2020
31
2
8
35
Why do you have a /etc/network/interfaces.d/50-cloud-init file on your proxmox host ????

cloud-init is used inside the vms, but not on host.

just remove this /etc/network/interfaces.d/50-cloud-init (and check that cloud-init package is not installed)
After deleting the file, everything works normally.
I will nevertheless reinstall the server to see if the file is not part of the OVH installation.
Because the only packages that I installed on my side are "libpve-network-perl" and "ifupdown2".

I will put the subject in resolved within a few hours, when I have posted my feedback on the test.

Thanks again @spirit
 

daruom13

Member
Aug 1, 2020
31
2
8
35
After deleting the file, everything works normally.
I will nevertheless reinstall the server to see if the file is not part of the OVH installation.
Because the only packages that I installed on my side are "libpve-network-perl" and "ifupdown2".

I will put the subject in resolved within a few hours, when I have posted my feedback on the test.

Thanks again @spirit
I did the reinstallation, and the file is existing by default.
I took the opportunity to create a VM with proxmox install via ISO, and no file of this type.
This comes from OVH.
 

spirit

Famous Member
Apr 2, 2010
5,782
676
133
www.odiso.com
I did the reinstallation, and the file is existing by default.
I took the opportunity to create a VM with proxmox install via ISO, and no file of this type.
This comes from OVH.
Ok thanks for the report !
This is strange than OVH install cloudinit config. I'll add a note in documentation about this.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!