DiskIO in CT missing

Oct 26, 2017
28
5
23
27
I had hoped for a nice little surprice with the release of PVE 7.1, but sadly, no change.

pve-manager/7.1-5/6fe299a0

proxmox-ve: 7.1-1 (running kernel: 5.11.22-4-pve)
pve-manager: 7.1-5 (running version: 7.1-5/6fe299a0)
pve-kernel-5.13: 7.1-4
pve-kernel-helper: 7.1-4
pve-kernel-5.11: 7.0-10
pve-kernel-5.4: 6.4-4
pve-kernel-5.13.19-1-pve: 5.13.19-2
pve-kernel-5.11.22-7-pve: 5.11.22-12
pve-kernel-5.11.22-5-pve: 5.11.22-10
pve-kernel-5.11.22-4-pve: 5.11.22-9
pve-kernel-5.11.22-3-pve: 5.11.22-7
pve-kernel-5.11.22-2-pve: 5.11.22-4
pve-kernel-5.11.22-1-pve: 5.11.22-2
pve-kernel-5.4.124-1-pve: 5.4.124-1
pve-kernel-5.4.119-1-pve: 5.4.119-1
pve-kernel-5.4.114-1-pve: 5.4.114-1
pve-kernel-5.4.106-1-pve: 5.4.106-1
pve-kernel-5.4.103-1-pve: 5.4.103-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph-fuse: 14.2.21-1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: residual config
ifupdown2: 3.1.0-1+pmx3
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.0
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-2
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-14
libpve-guest-common-perl: 4.0-3
libpve-http-server-perl: 4.0-3
libpve-storage-perl: 7.0-15
libqb0: 1.0.5-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-4
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.0.14-1
proxmox-backup-file-restore: 2.0.14-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.4-2
pve-cluster: 7.1-2
pve-container: 4.1-2
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-3
pve-ha-manager: 3.3-1
pve-i18n: 2.6-1
pve-qemu-kvm: 6.1.0-2
pve-xtermjs: 4.12.0-1
qemu-server: 7.1-3
smartmontools: 7.2-pve2
spiceterm: 3.2-2
swtpm: 0.7.0~rc1+2
vncterm: 1.7-1
zfsutils-linux: 2.1.1-pve3
 
Oct 26, 2017
28
5
23
27
Dominic hasn't been online on this forum since Aug 11, 2021, maybe he took some very long vacation and forgot to mention this issue to other staff members?
 

justkru

New Member
Mar 31, 2022
1
0
1
same here. version 7.1-4 - still not fixed.
LXCs using ZFS do not report io stats. any hotfix or manual fix possible?
 

Skyrider

Member
May 11, 2020
31
1
13
35
Can confirm. Just a shame from the looks of it, this is being ignored.
 
Last edited:

Alibek

Active Member
Jan 13, 2017
98
11
28
43
People:
1) diskIO stat is present in container if it is unprivileged.
2) for privileged container diskIO stat is not present.

# pveversion
pve-manager/5.4-15/d0ec33c6 (running kernel: 4.15.18-30-pve)

# pveversion
pve-manager/7.2-5/12f1e639 (running kernel: 5.15.35-3-pve)
 

Corwin

Active Member
Jan 26, 2016
34
0
26
FR
Unfortunately diskIO stat is NOT present in container even if it is unprivileged, just checked on 7.2 (zfs system selected during installation).
Any ideas ?
 

erfus

Member
Sep 17, 2020
6
0
6
24
Same issue here unfortunately. Running latest PVE7 with zfs. Disk Stats on VMs are fine but no Disk Stats on CT. Any way to solve this? Thanks!
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,889
1,511
164
see the bug report linked on the first page - there is no accounting for non-block-devices, so storages which use bind-mount(-like) semantics like ZFS don't have any usage numbers available.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!