/dev/ttyACM0 not showing

aC23

New Member
Nov 21, 2019
7
0
1
42
Hi,

For some reason, /dev/ttyACM0 is no longer coming up when plugging in my ZWave USB stick. When I plug it in, the following message comes up on the host:

Code:
dmesg

usb 1-11: new full-speed USB device number 7 using xhci_hcd
usb 1-11: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
usb 1-11: New USB device strings: Mfr=0, Product=0, SerialNumber=0
cdc_acm 1-11:1.0: ttyACM0: USB ACM device
usb 1-11: reset full-speed USB device number 7 using xhci_hcd
usb 1-11: reset full-speed USB device number 7 using xhci_hcd
cdc_acm 1-11:1.0: ttyACM0: USB ACM device
I've ruled out a hardware issue with the stick itself by confirming it worked on another device. I passed it through to my Windows VM which saw it just fine. Then I passed it through to another Linux VM on the host which also saw it just fine and created /dev/ttyACM0, which leads me to believe that something within the host is the problem.

This is the only device giving me trouble, I've connected USB drives and other devices just fine on the host... Any ideas?

Thanks
 
Last edited:

aC23

New Member
Nov 21, 2019
7
0
1
42
Looks like the stick just randomly started getting recognized and ttyACM0 is now showing. It was plugged in for over a day.
 
Last edited:

aC23

New Member
Nov 21, 2019
7
0
1
42
Nevermind, it isn't stable as it comes upand goes away periodically. Would love it if someone can help with this as it is definitely a Proxmox issue
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
921
93
28
hi,

* how do you do the passthrough?

* VM or CT?

* pveversion -v
 

aC23

New Member
Nov 21, 2019
7
0
1
42
-Passthrough is occurring in /etc/pve/lxc/<container_id>.conf
-CT

The issue is with the host itself though, not the container. The container actually shows /dev/ttyACM0 from before it stopped working, but it isn't functional due to the host not actually seeing it.


pveversion -v output:

Code:
proxmox-ve: 6.0-2 (running kernel: 5.0.21-5-pve)
pve-manager: 6.0-15 (running version: 6.0-15/52b91481)
pve-kernel-helper: 6.0-12
pve-kernel-5.0: 6.0-11
pve-kernel-4.15: 5.4-7
pve-kernel-5.0.21-5-pve: 5.0.21-10
pve-kernel-5.0.21-3-pve: 5.0.21-7
pve-kernel-5.0.18-1-pve: 5.0.18-3
pve-kernel-4.15.18-19-pve: 4.15.18-45
pve-kernel-4.15.18-18-pve: 4.15.18-44
pve-kernel-4.15.18-10-pve: 4.15.18-32
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.2-pve4
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.13-pve1
libpve-access-control: 6.0-5
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-9
libpve-guest-common-perl: 3.0-3
libpve-http-server-perl: 3.0-3
libpve-storage-perl: 6.0-12
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve3
lxc-pve: 3.2.1-1
lxcfs: 3.0.3-pve60
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.1-1
pve-cluster: 6.0-9
pve-container: 3.0-14
pve-docs: 6.0-9
pve-edk2-firmware: 2.20191002-1
pve-firewall: 4.0-8
pve-firmware: 3.0-4
pve-ha-manager: 3.0-5
pve-i18n: 2.0-3
pve-qemu-kvm: 4.1.1-2
pve-xtermjs: 3.13.2-1
qemu-server: 6.1-1
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.2-pve2

Edit 1: To further confirm that this is an issue with the Proxmox host, I created a Proxmox VM, passed through the USB and my Proxmox VM saw the device and created /dev/ttyACM0 just fine.

Edit 2: So this is interesting. It's now showing after having passed it through to the Proxmox VM. I think that's why I thought it was working before when I created another VM to test it with.
 
Last edited:

aC23

New Member
Nov 21, 2019
7
0
1
42
Reverted to kernel version 5.0.21-3-pve from 5.0.21-5-pve and the issue is no longer occurring. No more error messages when running dmesg
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
921
93
28
hi,

Reverted to kernel version 5.0.21-3-pve from 5.0.21-5-pve and the issue is no longer occurring. No more error messages when running dmesg
can you make a bug report on bugzilla.proxmox.com ?

if you do, please attach your container configuration, dmesg output, pveversion -v output and any other relevant information you can think of.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!