/dev/mapper/pve-root does not exist

SialoS

New Member
Nov 25, 2023
2
1
1
I ve been having this problem over and over again and i cannot figure this out. Over the past year because of this problem i have formatted and reinstalled Proxmox 6 times. I dont understand what i am doing wrong so please help.
This time i updated from proxmox 8 to 8.1 and upon rebooting i get this error.
I tried rootdelay=10 and i removed everything from global filter in lvm.cnf, just to be sure.
I also tried to boot with the old kernels and nothing works.
I used Ubuntu live and the drive seems ok.

Please talk to me like i am stupid, because i am.
 

Attachments

  • PXL_20240202_190631656~2.jpg
    PXL_20240202_190631656~2.jpg
    752.8 KB · Views: 12
Last edited:
Are you sure your hardware is fine? Not that bad RAM, bad disk or bad PSU are corrupting your storage.
 
The problem only occurs when i reboot proxmox. This is a new pc and new disk. I changed the ram 2 months ago and i had this issue with the old and the new ram.
Its working fine until i reboot. For the past 3 months i didn't had this issue and after the last install i rebooted proxmox multiple times to see if its working ok and it was.
Today after the upgrade i rebooted and got the same death screen i came to fear so much.
 
Last edited:
  • Like
Reactions: gallophile21
I have also just run into this issue after updating the Debian installation (related to another issue I ran into).

I wonder if there is something about the GRUB updates that overwrites a relevant Proxmox file?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!