[SOLVED] Debian 12.1 cloud image template network problem?


New Member
Dec 29, 2022
Hi, I saw that Debian 12 was updated to 12.1 and I thought of making new cloud template.
I run 2 Proxmox 8 servers, 1 in Hetzner and 1 at home, the problem i am facing can be reproduced in both of them.
The steps I did to make the template are:

1) wget https://cloud.debian.org/images/clo...0/debian-12-generic-amd64-20230723-1450.qcow2
2) qm create 8000 --memory 2048 --core 2 --name debian12-cloud --net0 virtio,bridge=vmbr0 --ostype l26
3) qm importdisk 8000 debian-12-generic-amd64-20230723-1450.qcow2 local
4) qm set 8000 --scsihw virtio-scsi-pci --scsi0 local:vm-8000-disk-0
5) qm set 8000 --ide2 local:cloudinit
6) qm set 8000 --boot c --bootdisk scsi0
7) qm set 8000 --serial0 socket --vga serial0
8) Config the vm and cloudinit
9) qm template 8000

Basically I use the same commands to make Ubuntu and Debian cloud image templates.

Now when i make the template like that, I make a full clone of it and boot it up, it always stays long time at networks, it continues after a while but when get it, the vm doesn't have network access at all.
As I login, I type: ip a
And I get: 2: ensl8: BROADCAST,MULTICAST mtu 1500 qdisc noop state DOWN group default qlen 1000 link/ether mac:address brd altname enp0s!8

I have tried to change the nic from virtIO to intel or realtek but it is always the same.
Thankfully I had taken a backup of the 12.0 template and restored that and it works fine.
I assume this is a Debian 12.1 cloud image problem or is there any setting I have done wrong?
Thanks for the reply,"qm set 8000 -sshkeys ~/.ssh/id_rsa.pub" I am setting ssh keys in the cloud-init but i will try the "qm set 8000 -ipconfig0 ip=dhcp" even though I am pretty sure this is the default and I have been using this form for templates for months without issues. It is just debian12.1 that gives me troubles
booting an unmodified image without "-ipconfig":
[ *** ] Job systemd-networkd-wait-online.se…tart running (1min 10s / no limit)

shut it down and add "-ipconfig"
[ 9.093766] cloud-init[321]: ci-info: | eth0 | True | | | global | 4e:ba:2c:94:64:11 |

I am not going to attempt to bisect the image to find out why there is a difference, but if you have free time and want to report back - I'd be curios.

If you feel there is a problem with image and it shouldnt behave as it does, you can report it to maintainers.

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
  • Like
Reactions: compiz
This seems to have done the trick qm set 8000 -ipconfig0 ip=dhcp and thank you for your answer :)
I just find it odd that if I do the procedure from scratch again but with debian 12.0 or 11.7 or ubuntu 22.04.2 it works without it!
Anyway! thanks again, problem solved!
  • Like
Reactions: bbgeek17
I am sorry for digging this one up, I have a question about a configuration for the cloud images.
I see in terminal with the command "parted -l" that the default FS for the VMs is EXT4, is there any command I can run to the cloud-init to make it use btrfs or zfs instead of EXT4?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!