copy paste issue using xterm.js from workstation to vm

tlex

Member
Mar 9, 2021
87
6
8
41
When I try to paste content from my workstation to a vm while in console with xterm.js, that will work to paste 2-10 lines of code. But if I try to paste more content like 30-100 lines, the session will "disconnect" and eventually reconnect without having paste anything.
Does that have to do wit some buffer limitation ? Can this be edited somewhere ?
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,638
1,125
174
34
Vienna
works here...
can you post the vm config (qm config ID) or ct config (pct config ID)?
also what is running inside the vm/ct? (meaning where do you paste it to ?)
 

tlex

Member
Mar 9, 2021
87
6
8
41
vm is pfsense (freebsd 12.3)
trying to copy in nano, but also tried ee
copying from a mac on safari, but also tried chrome.
Once paste a big chunk, webconsole will hang, sometime disconnect. I have to go with xvnc or ssh to kill the process.
If I paste to proxmox host web console itself instead of a vm, that works...

I had freebsd configured as :

/etc/ttys:
# name getty type status comments # # If console is marked "insecure", then init will ask for the root password # when going to single-user mode. console "/usr/libexec/getty Pc" xterm on secure # ttyv0 "/usr/libexec/getty Pc" xterm onifexists secure # Virtual terminals ttyv1 "/usr/libexec/getty Pc" xterm onifexists secure ttyv2 "/usr/libexec/getty Pc" xterm onifexists secure ttyv3 "/usr/libexec/getty Pc" xterm onifexists secure ttyv4 "/usr/libexec/getty Pc" xterm onifexists secure ttyv5 "/usr/libexec/getty Pc" xterm onifexists secure ttyv6 "/usr/libexec/getty Pc" xterm onifexists secure ttyv7 "/usr/libexec/getty Pc" xterm onifexists secure ttyv8 "/usr/local/bin/xdm -nodaemon" xterm off secure # Serial terminals # The 'dialup' keyword identifies dialin lines to login, fingerd etc. ttyu0 "/usr/libexec/getty 3wire" vt100 off secure ttyu1 "/usr/libexec/getty 3wire" vt100 off secure ttyu2 "/usr/libexec/getty 3wire" vt100 off secure ttyu3 "/usr/libexec/getty 3wire" vt100 off secure # Dumb console dcons "/usr/libexec/getty std.9600" vt100 off secure xc0 "/usr/libexec/getty Pc" xterm onifexists secure

qm config 1001
bios: ovmf boot: order=virtio0;net0 cores: 8 memory: 8192 meta: creation-qemu=6.1.1,ctime=1645039349 name: PfSense net0: virtio=00:0a:f7:50:a0:83,bridge=vmbr1,tag=35 net1: virtio=06:5A:35:03:C6:5B,bridge=vmbr0 numa: 0 onboot: 1 ostype: l24 protection: 1 scsihw: virtio-scsi-pci serial0: socket smbios1: uuid=76400d77-d743-4f33-ab04-28ce65a96752 sockets: 2 startup: order=1,up=60 vga: std virtio0: R1_1.6TB_SSD_EVO860:vm-1001-disk-0,size=32G vmgenid: f058a37c-f729-40e3-8577-06b54fc60b31
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!