Connect several nodes to the same iSCSI volume

Discussion in 'Proxmox VE: Installation and configuration' started by omegared77, Mar 15, 2019 at 11:15.

Tags:
  1. omegared77

    omegared77 New Member

    Joined:
    Feb 4, 2019
    Messages:
    4
    Likes Received:
    0
    Hey,

    I'm trying to mount the same iSCSI LUN (on a HP MSA) on my 2 nodes
    upload_2019-3-15_11-8-45.png

    On top of the iSCSI volume, I created a LVM :
    upload_2019-3-15_11-9-37.png

    I noticed that on the node I didn't use for creating the LVM, there's no pv or lv :

    Node 1 (works fine)
    upload_2019-3-15_11-11-37.png

    Node 2 :
    upload_2019-3-15_11-12-38.png
    upload_2019-3-15_11-12-50.png

    Any advice ?
     

    Attached Files:

  2. menk

    menk Member

    Joined:
    Apr 3, 2014
    Messages:
    34
    Likes Received:
    1
  3. menk

    menk Member

    Joined:
    Apr 3, 2014
    Messages:
    34
    Likes Received:
    1
    do you have select "shared" option when create lvm???
     
  4. omegared77

    omegared77 New Member

    Joined:
    Feb 4, 2019
    Messages:
    4
    Likes Received:
    0
    I could finally fix it.
    On a host, the LUN was seen as enclosure instead of disk

    Rinning modprobe -r mptsas;sleep 1; modprobe mptsas fixed it
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice