Cluster in "Standalone node - no cluster defined"

It seems the problem in my case was that the join process was interrupted somehow.
I powered off the new node and removed it using
pvecm delnode <nodename>
After that I reinstalled PVE on it, re-configured it and joined the cluster again.

This time the join worked.
After this I had to fix the SSH keys on the new node and the cluster is stable now.

Maybe this helps someone with the same issue.
I had the same problem. Web UI said no cluster defined, but everything was setup up correctly including name resolution.

root@dllohsr287:~# pvesh get /cluster/config/join --output-format json-pretty
'/etc/pve/nodes/dllohsr286/pve-ssl.pem' does not exist!

I did go to dllohsr286 and did

root@dllohsr286:~# pvecm updatecerts
(re)generate node files
merge authorized SSH keys and known hosts

that fixed it. You can also notice that something is wrong, when SSH asks you for fingerprint (it shouldnt when everything is right)
I also had really big problems in the UI without doing this (because node2 did not respond to any actions I would like to take)
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!