Cluster doesn't exist after removing node

jonathan bolich

New Member
Mar 11, 2019
I am new to proxmox and have found it to be great. I have setup a 4 node cluster, but needed to remove one node. I followed the instructions and command pvecm delnode. I ran this after doing a shutdown of the node I wanted to remove. I received no errors when doing this.
I also removed the node's folder in order for it be removed from the GUI. This folder removal was synced to the other nodes. Everything looked good until I ran pvecm status. It shows expected votes to still be at 4. Then from the GUI, it still shows the removed node as offline and under cluster, it says I'm no in standalone mode and that I need to create a cluster.
I tried doing a reboot on one of the nodes and this didn't change anything.

Thank you for any help you can provide. below is the output from the status command.

root@Vpve1:/etc/pve/nodes# pvecm status
Quorum information
Date: Mon Mar 11 10:55:09 2019
Quorum provider: corosync_votequorum
Nodes: 3
Node ID: 0x00000004
Ring ID: 4/236
Quorate: Yes

Votequorum information
Expected votes: 4
Highest expected: 4
Total votes: 3
Quorum: 3
Flags: Quorate

Membership information
Nodeid Votes Name
0x00000004 1 (local)
0x00000002 1
0x00000001 1
Got it straightened out. Had to modify the corosync.conf file and remove the deleted node from it. after that, restarted the corosync service and all is good now.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!