Clock on VM using Proxmox 5

Discussion in 'Proxmox VE: Installation and configuration' started by Mecanik, Mar 2, 2018.

  1. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
    Is there a way to stop the VM clock from changing it's timezone to the host timezone ? I really had no such issues with Proxmox 4, but it seems for some reason I have this on Proxmox 5.

    Basically the node has 1 timezone and the VM needs to have it's own timezone inside Windows OS, but it changes randomly back to the node's timezone.

    Could you advise ?

    Thank you!
     
  2. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    3,592
    Likes Received:
    325
    proxmox does not (and can not) change the timezone of the guest
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
    That is what I thought as well, but it's happening on 2 nodes with Proxmox 5, so then what does change the timezone to the node's timezone...
     
  4. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    3,592
    Likes Received:
    325
    i guess windows tries to set its timezone based on location/network ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
    I already tried that, change to internet timezone, tried everything and it will change all over again...
     
  6. Datajock

    Datajock New Member

    Joined:
    Jan 14, 2019
    Messages:
    1
    Likes Received:
    0
    I am wondering if the "time zone" is being changed or if the "time" is only being set to that of a different time zone. These are two different things. I am having issues where I want my Windows VM to use MT and the host is using UTC. If I set the VM to UTC, all is fine. But when I try and set the VM to MT, it still sets the time inside the VM to UTC time (it does not change the time zone, it just has the wrong time, or the time from UTC instead of MT).

    Is this what the original poster is seeing as well or are they actually seeing the time zone get changed?
     
    #6 Datajock, Jan 14, 2019
    Last edited: Jan 14, 2019
  7. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
    I am actually seeing the timezone changed/reset inside the VM to the host timezone. No matter what I do.
     
  8. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
    So there is no definitive answer to this ? I really can't believe it. The time on the machine changes without reason.

    I also tried to enable Use local time for RTC: YES, but still the time changes inside the VM.

    For example:

    March 30,2019 Saturday 1:00AM (UTC+8) Timezone: Singapore

    It's automatically changed into:

    March 29,2019 Friday 5:00PM but the time zone remain the same.

    How can this even be happening ? Please advise...
     
  9. Mecanik

    Mecanik Member

    Joined:
    Mar 2, 2017
    Messages:
    75
    Likes Received:
    2
  10. EntonyBirk

    EntonyBirk New Member

    Joined:
    Apr 8, 2019
    Messages:
    5
    Likes Received:
    0
    You tried, in that case, you would be best to use UTC for the VM RTC and ensure that the VM OS is aware that the RTC is in UTC.
     
  11. Instigater

    Instigater New Member

    Joined:
    Aug 27, 2015
    Messages:
    12
    Likes Received:
    0
    I was very dissapointed today to find out after a week long struggle with Windows timezone offset. No matter what I did, Windows turned its time to Proxmox timezone, UTC in my case. I had to change my Proxmox host to my local timezone to force Windows not to change time to UTC.

    Developers, please make a possibility into virtual machine configuration to specify time offset or time zone.
     
  12. Shusky

    Shusky New Member

    Joined:
    Feb 19, 2018
    Messages:
    6
    Likes Received:
    1
    There is a workaround for this:
    1) Set "Linux" as the operating system for Windows VMs within Proxmox.
    2) Create the DWORD-Key "RealTimeIsUniversal" within Windows at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation and set the value to "1".
    3) Reboot the VM and set the correct time zone.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice