[SOLVED] Change ring address to node in cluster


Active Member
Aug 1, 2017

During cluster creation I forgot to add ring address to one of the nodes resulting it to be added in wrong network.

How can I fix this?

I was thinking to remove node and add again but documentation says removed nodes can't be added back.

The node is part of a Ceph hyper-converged configuration.

Which is the correct procedure?

Thank you.
Thank you very much Chris, it worked.

In the pvecm status I see the name of the node I fixed showing old IP of wrong network. Is it possible to fix this too?

Then in web interface for cluster nodes summary I see some nodes with "Server Address" as public IP and some as local one, but in cluster information page I see correct Ring 0 local address.

Thank you.
Last edited:
Did you restart corosync by `systemctl restart corosync` on all nodes of the cluster one by one after editing?
I thought so, maybe I missed one, now is fixed.

Thank you again.

Have a nice day ;-)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!