Ceph HA

manues50

Active Member
Jul 25, 2019
58
0
26
35
Hello
I have two nodes in my cluster and was joined .
Now I was trying to enable ceph in both, I have successfully installed ceph in both servers, but the monitoring page is showing address: unknown, stopped for the second node

How can i troubleshoot the issues
 
First - Ceph needs 3 nodes for a reliable operation in production!

else -check the journal of the host: `journalctl -r`
also read the ceph logs: '/var/log/ceph/*'

I hope this helps!
 
I have only two Poxmox servers and 1 TB each . and need to configure HA
Which one is best GlusterFS or CephFS ? or any other?

The intention is if one Proxmox server down the second will deliver the service (for both VM and Container )
 
for HA to work properly you need at least 3 nodes (and an odd number is better) : https://pve.proxmox.com/pve-docs/chapter-ha-manager.html#_requirements

With 2 nodes I'd probably configure Storage replication with manual failover: https://pve.proxmox.com/pve-docs/chapter-pvesr.html

As an alternative you could add a qdevice to your setup instead of a third node - but this still would not take care of a reliable shared storage (but depending on your use-case storage-replication could be used)

I hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!