can't repair broken cluster

zystem

New Member
Feb 5, 2013
19
0
1
I have incorrect config in /etc/pve/cluster.conf
Cluster with this config can not find quorum.

I edit /etc/cluster/cluster.conf to fix problem. (fixing wrong line and adding expected_votes="1" to it)
i restart cman and it starts normally without errors

I need make /etc/pve writable (for fixing /etc/pve/cluster.conf) so i restart pve-cluster.
I have to ways:
1) config_version in /etc/cluster/cluster.conf is less than in /etc/pve/cluster.conf after that i receive
"wrote new cluster config '/etc/cluster/cluster.conf'"
/etc/cluster/cluster.conf replaced with old broken version and /etc/pve still ro
2) config_version in /etc/cluster/cluster.conf is greater than in /etc/pve/cluster.conf after that i receive
"Starting pve cluster filesystem : pve-cluster[dcdb] crit: local cluster.conf is newer"
and /etc/pve still ro

pveversion --verbose
proxmox-ve-2.6.32: 3.2-121 (running kernel: 2.6.32-27-pve)
pve-manager: 3.2-4 (running version: 3.2-4/e24a91c1)
pve-kernel-2.6.32-27-pve: 2.6.32-121
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.5-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.5-1
pve-cluster: 3.0-12
qemu-server: 3.1-16
pve-firmware: 1.1-3
libpve-common-perl: 3.0-18
libpve-access-control: 3.0-11
libpve-storage-perl: 3.0-19
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-6
vzctl: 4.0-1pve5
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 1.7-8
ksm-control-daemon: 1.1-1
glusterfs-client: 3.4.2-1

How a can repair my cluster.conf?
 

udo

Famous Member
Apr 22, 2009
5,866
161
83
Ahrensburg; Germany
I have incorrect config in /etc/pve/cluster.conf
Cluster with this config can not find quorum.

I edit /etc/cluster/cluster.conf to fix problem. (fixing wrong line and adding expected_votes="1" to it)
i restart cman and it starts normally without errors

I need make /etc/pve writable (for fixing /etc/pve/cluster.conf) so i restart pve-cluster.
I have to ways:
1) config_version in /etc/cluster/cluster.conf is less than in /etc/pve/cluster.conf after that i receive
"wrote new cluster config '/etc/cluster/cluster.conf'"
/etc/cluster/cluster.conf replaced with old broken version and /etc/pve still ro
2) config_version in /etc/cluster/cluster.conf is greater than in /etc/pve/cluster.conf after that i receive
"Starting pve cluster filesystem : pve-cluster[dcdb] crit: local cluster.conf is newer"
and /etc/pve still ro

pveversion --verbose
proxmox-ve-2.6.32: 3.2-121 (running kernel: 2.6.32-27-pve)
pve-manager: 3.2-4 (running version: 3.2-4/e24a91c1)
pve-kernel-2.6.32-27-pve: 2.6.32-121
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.5-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.5-1
pve-cluster: 3.0-12
qemu-server: 3.1-16
pve-firmware: 1.1-3
libpve-common-perl: 3.0-18
libpve-access-control: 3.0-11
libpve-storage-perl: 3.0-19
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-6
vzctl: 4.0-1pve5
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 1.7-8
ksm-control-daemon: 1.1-1
glusterfs-client: 3.4.2-1

How a can repair my cluster.conf?
Hi,
to repair you need quorum (writable /etc/pve).

See here: http://forum.proxmox.com/threads/7786-Cluster-and-quorum?p=59362#post59362

Udo
 

zystem

New Member
Feb 5, 2013
19
0
1
I have ANOTHER problem. pvecm expect vorking ONLY with cluster.conf WITHOUT mistakes in it.

pvecm expect 1
cman_tool: Cannot open connection to cman, is it running ?
 

zystem

New Member
Feb 5, 2013
19
0
1
may be best way is to disable check
"Starting pve cluster filesystem : pve-cluster[dcdb] crit: local cluster.conf is newer"
?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!