[SOLVED] Can't remove LVM


New Member
Dec 28, 2022
Hi everyone !
I have an issue with my Proxmox cluster, I can't delete any lvm.

The vm didn't exist anymore, but it say that the disk is used. I try with another disk with dmsetup:

I checked the block device in lsof and no output.
I don't know what I missed, if you have any idea or if you need more info lmk.
Edit1: Already tried to remove lvm with lvremove -f and dmsetup remove -f
Edit2: lvs output:
Don't really know how to interpret the first line error, gonna search about it
Edit3 problem solved: Veeamagent caused all the issue. The dm didn't seem busy with lsof but I think Veeam locked the dm. How ? Idk. Just had to remove all Veeam packages and the problem was solved.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!