Can't hide 'VM' status in Windows guest

Asgarda

New Member
Sep 23, 2021
3
0
1
32
Hello!

After 4 hours of searching info into the Internet, i've found.. nothing. Many "how-to" with GPU passthrough are telling, what it possible in Proxmox, but I don't need to passthrough GPU, I just need to hide VM status of my Windows guest machine.

In documentation, in "Options" section, where is "cpu" option for VM. It contains "hidden=<x>" parameter, that shoud 'disable' VM status of guest, but.. It doesn't work!

As I know, Proxmox based on Debian. At my home, I've machine with Kubuntu 20.04 with QEMU and Virt-Manager. And it works fine. At my work, VM on the server with Proxmox, situation is reverse. Is where any difference between Proxmox QEMU and Ubutnu QEMU?

I've try everything. Setting "hidden", adding "args: -cpu 'host,kvm=off'" string, enables and disables KVM in VM config, switching BIOS type.. and nothing helps me. How can I disable VM status of my virtual Windows guest? I've started to guess what it doesn't possible without GPU. Is it possible for VM without GPU passthrough?

ps./ I using Proxmox 6.4 and 7.0 (for test)
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
6,518
735
133
33
Vienna
its probably the automatic hv features we enable when you set the ostype to anything windows. try setting the ostype to linux or other and check if that helps

on another note: why do you want to hide it at all? even if windows task manager does not say 'virtual' it is not hard for a program to tell if it's running in a vm..
 

Asgarda

New Member
Sep 23, 2021
3
0
1
32
why do you want to hide it at all? even if windows task manager does not say 'virtual' it is not hard for a program to tell if it's running in a vm..
Some programs didn't start on VM or works not as expected. For example - drivers, games security systems and etc.

On my home WS I thought about switching my host Kubuntu to Proxmox and create two VMs with two separated GPUs: Linux for work purposes and Windows for gaming. With QEMU and VirtManager, as i wrote higher, I've achieved this and this works fine.

At my work I need to start software that are very critical sensitive where it starts: on VM or HW.

try setting the ostype to linux or other and check if that helps
This not helped... :(
 

Asgarda

New Member
Sep 23, 2021
3
0
1
32
I've found the solution. Just need to add "-hypervisor" key in "args: ..." string in VM configuration.

Hope it helps anybody who read this topic :)
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!