cannot migrate vm with local cd/dvd but i have NO local resources

Gerhard W. Recher

Active Member
Mar 10, 2017
158
8
38
Munich
I have no glue why live migration is NOT possible, vm has NO local resources.
any help is appreciated

Code:
 qm config 100
agent: 1
boot: order=scsi0;net0
cores: 2
memory: 16384
name: AD
net0: virtio=E2:9D:97:20:F8:8F,bridge=vmbr0,firewall=1
numa: 0
onboot: 1
ostype: win8
parent: voruseranlegen
scsi0: vmpool:vm-100-disk-0,cache=writeback,size=512G
scsihw: virtio-scsi-pci
smbios1: uuid=fb8b7c5d-6c6b-4a2a-a6d2-e55c51f2fe7e
sockets: 2
vmgenid: 101441d2-c0a7-474f-97c1-e5d845c67d40
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
8,144
1,588
164
possibly in a snapshot? please post 'pveversion -v' and the full error/task log..
 

Gerhard W. Recher

Active Member
Mar 10, 2017
158
8
38
Munich
possibly in a snapshot? please post 'pveversion -v' and the full error/task log..
yep, a snapshot is in place ... but snapshots are on vmpool in ceph ...

logs not avail pvemanager gui is blocking this ...

regards Gerhard

btw ... how to edit my signature, i can't find any option in my profile....

migrateerror.PNG
Code:
pveversion -v
proxmox-ve: 6.2-2 (running kernel: 5.4.65-1-pve)
pve-manager: 6.2-15 (running version: 6.2-15/48bd51b6)
pve-kernel-5.4: 6.2-7
pve-kernel-helper: 6.2-7
pve-kernel-5.4.65-1-pve: 5.4.65-1
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph: 14.2.11-pve1
ceph-fuse: 14.2.11-pve1
corosync: 3.0.4-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: residual config
ifupdown2: 3.0.0-1+pve3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.16-pve1
libproxmox-acme-perl: 1.0.5
libpve-access-control: 6.1-3
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.2-4
libpve-guest-common-perl: 3.1-3
libpve-http-server-perl: 3.0-6
libpve-storage-perl: 6.2-9
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.3-1
lxcfs: 4.0.3-pve3
novnc-pve: 1.1.0-1
proxmox-backup-client: 0.9.7-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.3-8
pve-cluster: 6.2-1
pve-container: 3.2-2
pve-docs: 6.2-6
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-3
pve-firmware: 3.1-3
pve-ha-manager: 3.1-1
pve-i18n: 2.2-2
pve-qemu-kvm: 5.1.0-6
pve-xtermjs: 4.7.0-2
qemu-server: 6.2-19
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 0.8.4-pve2
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
8,144
1,588
164
then check your snapshot configs, maybe they have a reference to a CD/DVD on local storage?
 
  • Like
Reactions: coinxu and fitbrian

Gerhard W. Recher

Active Member
Mar 10, 2017
158
8
38
Munich
then check your snapshot configs, maybe they have a reference to a CD/DVD on local storage?
indeed, snapshot was taken with install iso attached from local storage ...
so we have to take care to first dismount local cd roms prior to take a snapshot ....
this is new for me ...
 

greekforensics

New Member
Sep 27, 2022
1
0
1
I had the same issue.
I visited the following path /etc/pve/nodes/<NODE-NAME>/qemu-server/<vm_id.conf> and commented the lines of the snapshots containing records about digital media connected to CD roms.
I saved the file and it worked.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!