Can not boot Proxmox VE in RPI4

Robert Fichtinger

New Member
Jan 20, 2023
Possibly a very nooby question (and maybe more suited to RPI forums), but kind of stuck at this moment :(.

I am trying to install the Proxmox VE 7.3-1 ISO image on a blank RPI4, but it just does not boot the USB ISO image for some reason.

I have tried to verify if everything was working correctly in several ways.
- First I checked whether the eeprom was functioning correct, which I believe it was.
- I also checked whether the boot order was correct with a Raspberry OS Lite version on another USB made with Raspberry Pi Imager, and this worked normally.
(Not trying with `pimox, want to be able to update Proxmox as designed).

I have set up the (normally functioning) USB with balenaetcher, as instructed. What may I be missing here?
The PVE ISO requires a x86 system. If you want to run PVE on a Raspberry Pi you should look at some unofficial ports like this:

Also have the limitations in mind like not being able to use VMs because of missing virtualization features of ARM CPUs and so on. So you would need to stick with LXCs.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!