BUG? VM don't Stop, Shutdown, ...

abkrim

Active Member
Sep 5, 2009
95
1
28
Pastrana (España)
castris.com
A fresh install of VM (KVM) don't stop


  1. From web interface Stop menu.
  2. From Web Console Stop or Shutdown
  3. Only can halt form console..
But it's worng. If VM it's freeeze we'll can stop VM.

Message log:

Error: VM quit/powerdown failed - got timeout
 

abkrim

Active Member
Sep 5, 2009
95
1
28
Pastrana (España)
castris.com
What kind of VM (OS) is that?

Centos x64 y i386...
[B said:
Thijs Simonis]
[/B]
Search the PID of the machine with:
ps aux | grep "/usr/bin/kvm -id VMID"

Kill it with:
kill -9 PID

Start your machine again with:
qm start VMID

And look if you can stop your machine in GUI or CLI
CLI: qm stop VMID
I don't like STOP by force brute....
I like shutdown nicely.
Thanks for your tip
 

adamb

Renowned Member
Mar 1, 2012
1,165
44
68
I am also noticing this issue with CentOS-5.3 x86. Stop works, but shutdown does nothing. I don't like the idea of brute force either.

Apr 4 16:42:01 proxmox1 pvedaemon[70973]: shutdown VM 100: UPID:proxmox1:0001153D:001C9B7D:4F7CB219:qmshutdown:100:root@pam:
Apr 4 16:42:01 proxmox1 pvedaemon[67891]: <root@pam> starting task UPID:proxmox1:0001153D:001C9B7D:4F7CB219:qmshutdown:100:root@pam:
Apr 4 16:42:31 proxmox1 pvedaemon[70973]: VM quit/powerdown failed - got timeout
Apr 4 16:42:31 proxmox1 pvedaemon[67891]: <root@pam> end task UPID:proxmox1:0001153D:001C9B7D:4F7CB219:qmshutdown:100:root@pam: VM quit/powerdown failed - got timeout
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,693
662
133
did you enable acpid in your VM?

you need to allow anonymous acpi shutdown in all your KVM guest system to shutdown.
 

abkrim

Active Member
Sep 5, 2009
95
1
28
Pastrana (España)
castris.com
Yes for me, ACPI Support it's yes for all machines and for me don't work neither stop, shutdown or any for halt machine.

EDIT: Today work STOP, but shutdown got time out.
 
Last edited:

adamb

Renowned Member
Mar 1, 2012
1,165
44
68
On Linux you need to run the ACPI Daemon (acpid) inside the guest.

Yep that was the issue for me. On a side note I was unable to start the daemon while the VM was running. I had to add it to chkconfig then reboot for the daemon to properly start. Shutdown is working as it should.
 

hoppel118

Member
Apr 5, 2012
55
1
8
Hallo,

I have the same problem. Stop works, but shutdown doesn't. Sutdown ends up with the following error in "pve - tasks - status":

Error: VM quit/powerdown failed - got timeout


Under VM options the "ACPI Support" is activated "yes" und the acpid in the vm is working:

Code:
:~# /etc/init.d/acpid status
acpid is running.

I run the debian-distribution "openmediavault" as a vm with kernel "2.6.32-5-amd64".

What else can be done? What information do you need?

regards

Hoppel
 
Last edited:

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,693
662
133
install acpid in your guest.

Code:
aptitude install acpid
 

hoppel118

Member
Apr 5, 2012
55
1
8
Hey Tom,

acpid is allready installed in the newest version in the guest:

Code:
:~# apt-get install acpid
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
acpid ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

What else can be done? Do I need acpid on the pve-host?

acpid is not installed on the host.
 
Last edited:

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
14,693
662
133
check "System/Power Management" on OMV gui and enable "Shutdown the system when pressing the power button."
 

hoppel118

Member
Apr 5, 2012
55
1
8
Thanks, this was the solution, Shutdown works.

But I still see the message: Error: VM quit/powerdown failed - got timeout even though it works. Why?

-----------------------------------------------

EDIT: Curious, after I stopped the omv-vm once, I now get the message: OK while I use the shutdown button. So everything is as it should.

Thank you very much, Tom.

regards
 
Last edited:

darthanubis

Guest
EDIT: Curious, after I stopped the omv-vm once, I now get the message: OK while I use the shutdown button. So everything is as it should..[/QUOTE

What is omv-vm.
 

wdyslam

New Member
Mar 13, 2013
3
0
1
Hi All experts,

I encountered this issue recently.

my proxmox is 2.3, and creat new VM without any OS, but I can't shoudown the VM through console, the error log is "TASK ERROR: VM quit/powerdown failed - got timeout". i only force shutdown by qm stop ***.

do you have any suggestion about this issue, i don't want to force to shutdown VM everytime. thanks.
 

mo_

Member
Oct 27, 2011
399
3
18
Germany
if your VM doesnt have any OS, youre probably still looking at some installer loaded from some ISO. it is VERY likely that installers themselfs will not support ACPI, in fact I know most dont because you always have to press the off button for 3 seconds on a physical machine if the installer hangs because you messed something up.

Long story short: once you actually install some OS and enable ACPI support in it, clean shutdowns will work just fine.
 

chengkinhung

Member
Feb 11, 2016
17
4
23
20
Just encounter this error today, not way to stop VM in UI.
And command line also failed:
# qm stop 102
trying to acquire lock...
can't lock file '/var/lock/qemu-server/lock-102.conf' - got timeout
 

IT Hero

New Member
Aug 21, 2019
1
2
3
44
Sorry to necro this thread, but I think I know what the problem is, for future reference:

If you issue a Shutdown command on a VM than cannot process it (no ACPI), the task runs and tries its best before timing out. During this time the /var/lock/qemu-server/lock-100.conf is locked by this task.

If during this time (before the Shutdown task times out), you issue a Stop command to the VM, you become this error message:
trying to acquire lock...
TASK ERROR: can't lock file '/var/lock/qemu-server/lock-100.conf' - got timeout

In this case, you have to open the still running Shutdown *task* (double click on it in the Tasks pane) and stop it.

Then, re-issue the Stop command to the VM. This time it should work.

Just my 2 cents...
 
  • Like
Reactions: mediacj and wolfmon

raanasukumar

New Member
Jul 3, 2020
1
0
1
23
Encountered the same error, Shutdown from the Proxmox GUI or from console didn't work.
After multiple tries, I am able to power off VM after stopping it from the GUI.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!