[SOLVED] Backups not working: Unknown option: fullbackup

Discussion in 'Proxmox VE: Installation and configuration' started by elchorizo, Feb 14, 2019.

  1. elchorizo

    elchorizo New Member

    Joined:
    Feb 14, 2019
    Messages:
    4
    Likes Received:
    0
    I had backups working forever, now all of the sudden something changed and even when I try to run from command line its broken... I understand the error message, so obviously the command line switches changed. Not sure why the built in system isn't working though?

    Code:
    Unknown option: fullbackup
    400 unable to parse option
    vzdump {<vmid>} [OPTIONS]
    
    Full invocation is here:

    Code:
    vzdump 101 104 102 --fullbackup 7 --mailto blah@blah.com --mode snapshot --storage backup --quiet 1 --mailnotification always --maxfiles 7 --compress lzo
    
    Anyone have any ideas?
     
  2. elchorizo

    elchorizo New Member

    Joined:
    Feb 14, 2019
    Messages:
    4
    Likes Received:
    0
    I see the file /etc/pve/vzdump.cron has that in there, and another backup line without the --fullbackup option and it works, but it doesn't appear to be running that one. Just the errored one because backups are not running. Is this the file I need to modify? Or is it stored somewhere else as well?
     
  3. dcsapak

    dcsapak Proxmox Staff Member
    Staff Member

    Joined:
    Feb 1, 2016
    Messages:
    3,125
    Likes Received:
    288
    i do not see this option here anywhere, neither in the code
    did you maybe install ayufans differential backup patches and forgot?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. elchorizo

    elchorizo New Member

    Joined:
    Feb 14, 2019
    Messages:
    4
    Likes Received:
    0
    That may be possible. I wonder how I can remove those....
     
  5. elchorizo

    elchorizo New Member

    Joined:
    Feb 14, 2019
    Messages:
    4
    Likes Received:
    0
    Coped the patched files from an unpatched install and the problem seems to be fixed. Thanks for that tip, that was definitely it!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice