[SOLVED] Backup Error nach Update auf 9.X

Peterich

Active Member
Dec 18, 2019
6
0
41
37
Hallo zusammen,


ich habe mein Proxmox-System auf 9.X aktualisiert.
Das Update selbst lief fehlerfrei durch, lediglich im BIOS war bei einem der Server der Boot-Eintrag fehlerhaft. Nach Korrektur startete alles normal.


Jetzt habe ich aber ein Problem:
Ein LXC-Container mit Nextcloud lässt sich nicht mehr sichern. Ich vermute, das liegt an meinen verschachtelten Speicher-/Mountpoint-Strukturen.
Das Merkwürdige: Vor dem Update auf 9 hat das Backup noch funktioniert.


Meine Fragen:


  • Hat sich bei Proxmox 9 etwas an der Handhabung von verschachtelten Mountpoints geändert?
  • Gibt es eine Möglichkeit, das Backup wieder lauffähig zu bekommen, ohne alle Mountpoints anpassen zu müssen?
Container-Config:
Code:
arch: amd64
cores: 5
features: fuse=1,mount=nfs;cifs,nesting=1
hostname: nextcloud
memory: 8192
mp0: SSD1:subvol-161-disk-2,mp=/var/www/nextcloud-data,backup=1,mountoptions=noatime,size=100G
mp1: mRAID5:subvol-161-disk-1,mp=/var/www/nextcloud-data/user1,mountoptions=noatime,replicate=0,size=38524G
mp10: mRAID5:subvol-161-disk-10,mp=/var/www/nextcloud-data/user2,backup=1,mountoptions=noatime,size=2500G
mp11: SSD1:subvol-161-disk-0,mp=/var/www/nextcloud-data/appdata_X,backup=1,mountoptions=noatime,size=50G
mp12: SSD1:subvol-161-disk-3,mp=/var/www/nextcloud-data/appdata_X/preview,backup=1,mountoptions=noatime,size=100G
mp2: mRAID5:subvol-161-disk-2,mp=/var/www/nextcloud-data/user3,backup=1,mountoptions=noatime,size=200G
mp3: mRAID5:subvol-161-disk-3,mp=/var/www/nextcloud-data/user4,backup=1,mountoptions=noatime,size=100G
mp4: mRAID5:subvol-161-disk-4,mp=/var/www/nextcloud-data/user5,backup=1,mountoptions=noatime,size=50G
mp5: mRAID5:subvol-161-disk-5,mp=/var/www/nextcloud-data/user6,backup=1,mountoptions=noatime,size=25G
mp6: mRAID5:subvol-161-disk-6,mp=/var/www/nextcloud-data/user7,backup=1,mountoptions=noatime,size=100G
mp7: mRAID5:subvol-161-disk-7,mp=/var/www/nextcloud-data/user8,backup=1,mountoptions=noatime,size=100G
mp8: mRAID5:subvol-161-disk-8,mp=/var/www/nextcloud-data/user9,backup=1,mountoptions=noatime,size=100G
mp9: mRAID5:subvol-161-disk-9,mp=/var/www/nextcloud-data/user10,backup=1,mountoptions=noatime,size=100G
net0: name=eth0,bridge=vmbr2,firewall=1,gw=10.0.0.1,hwaddr=X,ip=10.10.3.61/8,type=veth
onboot: 1
ostype: debian
rootfs: SSD1:subvol-161-disk-1,size=25G
startup: order=200
swap: 0
tags: basics;nc

Proxmox-Version:
Code:
proxmox-ve: 9.0.0 (running kernel: 6.8.12-13-pve)
pve-manager: 9.0.5 (running version: 9.0.5/9c5600b249dbfd2f)
proxmox-kernel-helper: 9.0.3
proxmox-kernel-6.14.8-2-pve-signed: 6.14.8-2
proxmox-kernel-6.14: 6.14.8-2
proxmox-kernel-6.8.12-13-pve-signed: 6.8.12-13
proxmox-kernel-6.8: 6.8.12-13
ceph-fuse: 19.2.3-pve1
corosync: 3.1.9-pve2
criu: 4.1.1-1
frr-pythontools: 10.3.1-1+pve4
ifupdown: not correctly installed
ifupdown2: 3.3.0-1+pmx9
intel-microcode: 3.20250211.1~deb12u1
libjs-extjs: 7.0.0-5
libproxmox-acme-perl: 1.7.0
libproxmox-backup-qemu0: 2.0.1
libproxmox-rs-perl: 0.4.1
libpve-access-control: 9.0.3
libpve-apiclient-perl: 3.4.0
libpve-cluster-api-perl: 9.0.6
libpve-cluster-perl: 9.0.6
libpve-common-perl: 9.0.9
libpve-guest-common-perl: 6.0.2
libpve-http-server-perl: 6.0.4
libpve-network-perl: 1.1.6
libpve-rs-perl: 0.10.10
libpve-storage-perl: 9.0.13
libspice-server1: 0.15.2-1+b1
lvm2: 2.03.31-2+pmx1
lxc-pve: 6.0.4-2
lxcfs: 6.0.4-pve1
novnc-pve: 1.6.0-3
proxmox-backup-client: 4.0.14-1
proxmox-backup-file-restore: 4.0.14-1
proxmox-backup-restore-image: 1.0.0
proxmox-firewall: 1.1.1
proxmox-kernel-helper: 9.0.3
proxmox-mail-forward: 1.0.2
proxmox-mini-journalreader: 1.6
proxmox-offline-mirror-helper: 0.7.0
proxmox-widget-toolkit: 5.0.5
pve-cluster: 9.0.6
pve-container: 6.0.9
pve-docs: 9.0.8
pve-edk2-firmware: not correctly installed
pve-esxi-import-tools: 1.0.1
pve-firewall: 6.0.3
pve-firmware: 3.16-3
pve-ha-manager: 5.0.4
pve-i18n: 3.5.2
pve-qemu-kvm: 10.0.2-4
pve-xtermjs: 5.5.0-2
qemu-server: 9.0.18
smartmontools: 7.4-pve1
spiceterm: 3.4.0
swtpm: 0.8.0+pve2
vncterm: 1.9.0
zfsutils-linux: 2.3.3-pve1
Backup-Log:
Code:
{{guestname}}
INFO: starting new backup job: vzdump 161 --notification-mode notification-system --remove 0 --node SRV01 --mode snapshot --storage pbs --notes-template '{{guestname}}'
INFO: Starting Backup of VM 161 (lxc)
INFO: Backup started at 2025-08-23 10:03:46
INFO: status = running
INFO: CT Name: nextcloud
INFO: including mount point rootfs ('/') in backup
INFO: including mount point mp0 ('/var/www/nextcloud-data') in backup
INFO: excluding volume mount point mp1 ('/var/www/nextcloud-data/user1') from backup (disabled)
INFO: including mount point mp2 ('/var/www/nextcloud-data/user3') in backup
INFO: including mount point mp3 ('/var/www/nextcloud-data/user4') in backup
INFO: including mount point mp4 ('/var/www/nextcloud-data/user5') in backup
INFO: including mount point mp5 ('/var/www/nextcloud-data/user6') in backup
INFO: including mount point mp6 ('/var/www/nextcloud-data/user7') in backup
INFO: including mount point mp7 ('/var/www/nextcloud-data/user8') in backup
INFO: including mount point mp8 ('/var/www/nextcloud-data/user9') in backup
INFO: including mount point mp9 ('/var/www/nextcloud-data/user10') in backup
INFO: including mount point mp10 ('/var/www/nextcloud-data/user2') in backup
INFO: including mount point mp11 ('/var/www/nextcloud-data/appdata_X') in backup
INFO: including mount point mp12 ('/var/www/nextcloud-data/appdata_X/preview') in backup
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: suspend vm to make snapshot
INFO: create storage snapshot 'vzdump'
zfs_mount_at() failed: directory is not emptyumount: /mnt/vzsnap0/var/www/nextcloud-data: not mounted.
command 'umount -l -d /mnt/vzsnap0/var/www/nextcloud-data' failed: exit code 32
INFO: resume vm
INFO: guest is online again after 2 seconds
ERROR: Backup of VM 161 failed - command 'mount -o ro -t zfs SSD1/subvol-161-disk-2@vzdump /mnt/vzsnap0//var/www/nextcloud-data' failed: exit code 2
INFO: Failed at 2025-08-23 10:03:48
INFO: Backup job finished with errors
WARN: 'root@pam' does not have a configured email address in the user configuration - not sending an email to this user
ERROR: could not notify via target `mail-to-root`: could not notify via endpoint(s): mail-to-root: no recipients provided for the mail, cannot send it.
TASK ERROR: job errors
 
Code:
INFO: create storage snapshot 'vzdump'
zfs_mount_at() failed: directory is not emptyumount: /mnt/vzsnap0/var/www/nextcloud-data: not mounted.
command 'umount -l -d /mnt/vzsnap0/var/www/nextcloud-data' failed: exit code 32

Siehe:
und Nachfolgende.
 
Ich hatte den Beitrag schon gelesen.
Auf meiner Root-Disk gibt es ebenfalls den Ordner nextcloud-data. Wenn ich den lösche, shat die Nextcloud allerdings einen fehler. Nach einem Neustart wird der Ordner auch automatisch wieder erstellt.


Die Ordner sind allerdings leer, es befindet sich also nichts drin. Deshalb verstehe ich nicht, warum es trotzdem nicht funktioniert.


Oder habe ich das falsch verstanden?


KORREKTUR:

Nachdem ich das Ganze jetzt nochmal gemacht habe, funktioniert es komischerweise wieder.
 
Last edited:
Ich habe aktuell das gleiche Problem mit Proxmox Version 9.2.21.
Ein Container hat einen mountpoint und generiert einen falschen Mount-Pfad mit doppeltem "/".

Bash:
ERROR: Backup of VM 102 failed - command 'mount -o ro -o nosuid,acl -t zfs tank/proxmox-vm-storage/subvol-102-disk-0@vzdump /mnt/vzsnap0//var/www/html' failed: exit code 2

Das hat bisher immer gut funktoniert aber seit einem der letzten Updates nicht mehr. Weiß jeman mehr?
 
bitte die container config posten..
 
Hier die Konfiguration dazu:
INI:
arch: amd64
cores: 2
features: nesting=1
hostname: wiki
memory: 512
mp0: proxmox-vm-storage:subvol-102-disk-0,mp=/var/www/html,acl=1,backup=1,mountoptions=nosuid,size=0T
net0: name=eth0,bridge=vmbr0,firewall=1,gw=192.xxx.xxx.xxx,hwaddr=XXXXX,ip=192.xxx.xxx.xxx/24,type=veth
onboot: 1
ostype: ubuntu
parent: vzdump
rootfs: tank-vm:subvol-102-disk-0,size=8G
swap: 512
tags: produktiv
unprivileged: 1

[vzdump]
#vzdump backup snapshot
arch: amd64
cores: 2
features: nesting=1
hostname: wiki
memory: 512
mp0: proxmox-vm-storage:subvol-102-disk-0,mp=/var/www/html,acl=1,backup=1,mountoptions=nosuid,size=0T
net0: name=eth0,bridge=vmbr0,firewall=1,gw=192.xxx.xxx.xxx,hwaddr=XXXXX,ip=192.xxx.xxx.xxx/24,type=veth
onboot: 1
ostype: ubuntu
rootfs: tank-vm:subvol-102-disk-0,size=8G
snaptime: 1790756071
swap: 512
tags: produktiv
unprivileged: 1
 
steht im backup task log oder system log noch mehr, wenn der fehler auftritt?
 
steht im backup task log oder system log noch mehr, wenn der fehler auftritt?

Hier das gesammte Log dazu:

Code:
INFO: Starting Backup of VM 102 (lxc)
INFO: Backup started at 2026-09-29 23:11:29
INFO: status = running
INFO: CT Name: wiki
INFO: including mount point rootfs ('/') in backup
INFO: including mount point mp0 ('/var/www/html') in backup
INFO: found old vzdump snapshot (force removal)
INFO: backup mode: snapshot
INFO: ionice priority: 7
INFO: suspend vm to make snapshot
INFO: create storage snapshot 'vzdump'
freeze guest filesystem
thaw guest filesystem
zfs_mount_at() failed: directory is not emptyumount: /mnt/vzsnap0/var/www/html: not mounted.
command 'umount -l -d /mnt/vzsnap0/var/www/html' failed: exit code 32
INFO: resume vm
INFO: guest is online again after <1 seconds
ERROR: Backup of VM 102 failed - command 'mount -o ro -o nosuid,acl -t zfs tank/proxmox-vm-storage/subvol-102-disk-0@vzdump /mnt/vzsnap0//var/www/html' failed: exit code 2
INFO: Failed at 2026-09-29 23:11:30

Teilweise ist der Mountpoint danach noch belegt.

Code:
INFO: Starting Backup of VM 104 (lxc)
INFO: Backup started at 2026-09-29 23:11:30
INFO: status = running
INFO: CT Name: proxy
INFO: including mount point rootfs ('/') in backup
INFO: including mount point mp0 ('/proxy-storage') in backup
ERROR: Backup of VM 104 failed - mount point '/mnt/vzsnap0' not empty
INFO: Failed at 2026-09-29 23:11:30
INFO: Starting Backup of VM 105 (qemu)
 
du musst sicherstellen, das der ordner "var/www/html" im rootfs volume "tank-vm:subvol-102-disk-0" leer ist.

am einfachsten geht das im normalfall in dem du das rootfs volume mountest und dann schauts was da drin rumliegt, und den inhalt entweder woandershin verschiebst oder loescht.
 
du musst sicherstellen, das der ordner "var/www/html" im rootfs volume "tank-vm:subvol-102-disk-0" leer ist.

am einfachsten geht das im normalfall in dem du das rootfs volume mountest und dann schauts was da drin rumliegt, und den inhalt entweder woandershin verschiebst oder loescht.
Vielen Dank für diesen Hinweis.

Das Problem tritt durch den Backup auf, nicht durch meine Inkompetenz. Das vorherige BAckup nutzt diesen Mountpoit, es tritt ein Fehler und und der wird nicht mehr bereinigt.
Wie ich das händisch behben kann, ist mir schon klar. Ich möchte das aber nicht jeden Tag machen.
 
du verstehst mich falsch. bitte mach mal folgendes:

Code:
pct mount 102
umount /var/lib/lxc/102/rootfs/var/www/html
ls /var/lib/lxc/102/rootfs/var/www/html
pct unmount 102

und poste den output hier.
 
ZFS ist hier stenger geworden, frueher war der fault so ein nicht-leeres mountpoint verzeichnis zu ignorieren und trotzdem zu mounten, jetzt wirds standardmaessig nicht erlaubt..