[SOLVED] ArchLinux CT doesnt seem to play nice

Discussion in 'Proxmox VE: Installation and configuration' started by yswery, Apr 17, 2019.

  1. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    Hi team

    I just created a stock standerd container with the Proxmox downloaded ArchLinux template,

    On boot, when I enter the container I get the following errors:


    Code:
    [root@99999 ~]# systemctl status sys-kernel-config.mount
    ● sys-kernel-config.mount - Kernel Configuration File System
       Loaded: loaded (/usr/lib/systemd/system/sys-kernel-config.mount; static; vendor preset: disabled)
       Active: failed (Result: exit-code) since Wed 2019-04-17 07:02:34 UTC; 23s ago
        Where: /sys/kernel/config
         What: configfs
         Docs: https://www.kernel.org/doc/Documentation/filesystems/configfs/configfs.txt
               https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
    
    Apr 17 07:02:34 99999 mount[46]: mount: /sys/kernel/config: permission denied.
    
    Code:
    [root@99999 ~]# systemctl status sys-kernel-debug.mount 
    ● sys-kernel-debug.mount - Kernel Debug File System
       Loaded: loaded (/usr/lib/systemd/system/sys-kernel-debug.mount; static; vendor preset: disabled)
       Active: failed (Result: exit-code) since Wed 2019-04-17 07:02:34 UTC; 1min 10s ago
        Where: /sys/kernel/debug
         What: debugfs
         Docs: https://www.kernel.org/doc/Documentation/filesystems/debugfs.txt
               https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
    
    Apr 17 07:02:34 99999 mount[44]: mount: /sys/kernel/debug: permission denied.
    
    Can anyone know what I can do to fix this (it gives other issues when doing upgrades in pacman)
     
  2. Stoiko Ivanov

    Stoiko Ivanov Proxmox Staff Member
    Staff Member

    Joined:
    May 2, 2018
    Messages:
    1,229
    Likes Received:
    109
    Please try to enable the `nesting` feature for containers with newer systemd (like arch)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    I have enabled nesting and restart the container but still same errors, here is my conf for the container:


    Code:
    arch: amd64
    cores: 10
    hostname: 99999
    memory: 5120
    net0: name=eth0,bridge=vmbr0,firewall=1,hwaddr=B2:AC:AC:D1:51:48,type=veth
    ostype: archlinux
    rootfs: local-lvm:vm-99999-disk-0,size=8G
    swap: 512
    unprivileged: 1
    features: nesting=1
    
     
  4. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    Does anyone know how to get a default Archlinux system working as a container on proxmox? I tried a varient of things and still can not get these errors to work
     
  5. mac.linux.free

    Joined:
    Jan 29, 2017
    Messages:
    99
    Likes Received:
    5
    you need nesting=1 and keyctl=1

    but I migrated to debian to most of my containers
     
  6. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    I added keyctl=1 and rebooted, but still getting:

    Code:
    mount: /sys/kernel/config: permission denied.
     
  7. Stoiko Ivanov

    Stoiko Ivanov Proxmox Staff Member
    Staff Member

    Joined:
    May 2, 2018
    Messages:
    1,229
    Likes Received:
    109
    * the configfs and debugfs are not mountable in a container - quite sure because that would break isolation.
    However apart from the error-messages (which can be disabled by simply disabling/masking the corresponding mount-units) - what is not working?
    I quickly setup an archlinux container and upgraded it - it works here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    For example When installing openssh I get the following

    Code:
    [root@99999 ~]#  pacman -S openssh
    warning: openssh-7.9p1-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) openssh-7.9p1-1
    
    Total Installed Size:  4.65 MiB
    Net Upgrade Size:      0.00 MiB
    
    :: Proceed with installation? [Y/n]
    (1/1) checking keys in keyring                                                             [####################################################] 100%
    (1/1) checking package integrity                                                           [####################################################] 100%
    (1/1) loading package files                                                                [####################################################] 100%
    (1/1) checking for file conflicts                                                          [####################################################] 100%
    (1/1) checking available disk space                                                        [####################################################] 100%
    :: Processing package changes...
    (1/1) reinstalling openssh                                                                 [####################################################] 100%
    :: Running post-transaction hooks...
    (1/3) Reloading system manager configuration...
    (2/3) Creating temporary files...
    error: command failed to execute correctly
    (3/3) Arming ConditionNeedsUpdate...
    
    More specially:
    (2/3) Creating temporary files...error: command failed to execute correctly

    Which I assume is due to the mounting potentially?
     
  9. Stoiko Ivanov

    Stoiko Ivanov Proxmox Staff Member
    Staff Member

    Joined:
    May 2, 2018
    Messages:
    1,229
    Likes Received:
    109
    Ok - Thanks - can reproduce that error message here as well!
    * seems this comes from systemd-tmpfiles --create (see https://bbs.archlinux.org/viewtopic.php?id=237221)
    * during the run I get the following error in the journal:
    Code:
    Apr 19 11:01:17 archtest systemd-tmpfiles[222]: Failed to open file "/sys/devices/system/cpu/microcode/reload": Permission denied
    
    which is to be expected in a container
    * with some grepping - it seems that the package 'linux-firmware' ships a file which tries to access the file
    * AFAIK a container does not really need the package - so removing it also removes the error-message - `pacman -R linux-firmware`

    Apart from that I think that the message can be ignored as well

    Hope this helps!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    yswery and dkorzhevin like this.
  10. yswery

    yswery New Member

    Joined:
    May 6, 2018
    Messages:
    29
    Likes Received:
    0
    Thank you so much! Pleased with the final outcome
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice