[SOLVED] After upgrade to 7.3.3, GPU passthrough not working


New Member
Dec 8, 2022
Here is my step:

1) Fresh install a 7.2 version PVE
2) Upgrade to 7.3.3
3) Reboot it, that will show a "Proxmox Virtual Environment (5.15.74-1-pve)" in gurb.
4) Change the config from Proxmox official tutorial to enable PCI passthrough
5) Reboot
6) Restore a VM to run it with GPU passthrough (RX560)
7) Got an error "ASK ERROR: cannot prepare PCI pass-through, IOMMU not present"

Here is my grub:
Proxmox Virtual Environment (5.15.30-2-pve)
Proxmox Virtual Environment (5.15.74-1-pve)
Reboot Into Firmware Interface

If I choose "5.15.30-2-pve" to start, GPU pass-through is work, I would like to know why can't work in 5.15.74-1-pve?
Please show the output of cat /proc/cmdline.
If you have an Intel CPU: intel_iommu was enabled by default in some earlier version(s) and reverted later. If intel_iommu=on is not present then add it to the boot loader.
If it is present or you have an AMD CPU (where amd_iommu is always enabled by default), double check your BIOS settings. You would be surprised how often people install or update Proxmox and change the BIOS settings or update the BIOS or have a unexpected power loss that resets the BIOS settings. IOMMU needs to be (fully) enabled in the BIOS.
  • Like
Reactions: proale and Neobin
I'm using intel cpu, just checked that seems intel_iommu=on is not present...

# cat /proc/cmdline
initrd=\EFI\proxmox\5.15.74-1-pve\initrd.img-5.15.74-1-pve root=ZFS=rpool/ROOT/pve-1 boot=zfs

# proxmox-boot-tool kernel list
Manually selected kernels:

Automatically selected kernels:

I will double check the BIOS settings, but dont know why after upgraded a new kernel(5.15.74-1) then enable PCI passthrough, but only work in old kernel(5.15.30-2), it should be affect the new kernel... btw, I will try to add it to the boot loader, thanks!
Thanks leesteken for your advice!

After added intel_iommu=on and intel_iommu=pt to kernel, it solve my issue.

For anyone has the same issue, here is my step to solve it:
1) Add intel_iommu=on intel_iommu=pt into /etc/kernel/cmdline:
nano /etc/kernel/cmdline

Before /etc/kernel/cmdline:
root=ZFS=rpool/ROOT/pve-1 boot=zfs

After /etc/kernel/cmdline:
root=ZFS=rpool/ROOT/pve-1 boot=zfs intel_iommu=on iommu=pt

2) Save it

3) Update boot script:
proxmox-boot-tool refresh

4) Reboot

5) Check kernel cmdline:
cat /proc/cmdline

Should be show below result:
initrd=\EFI\proxmox\5.15.74-1-pve\initrd.img-5.15.74-1-pve root=ZFS=rpool/ROOT/pve-1 boot=zfs intel_iommu=on iommu=pt
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!