Adguard LXC 100% Auslastung auf Proxmox

Ronny1978

Member
Mar 13, 2023
58
12
8
Hallo Zusammen,

leider ist es mir jetzt innerhalb 2 Wochen schon 3x passiert, dass mein DNS nicht mehr funktioniert. Nach kurzer Suche habe ich gemerkt, dass der Adguard im LCX Container auf 100% Auslastung war. Ich habe den Container neu gestartet und dann ging es wieder. Aber das ist ja keine Lösung. Habt jemand auch schon einmal das Problem bemerkt?

Gibt es eine Fehlerursache oder noch schöner, eine Lösung?

Folgendes ist mir im Syslog aufgefallen:

Code:
Jul 01 11:21:01 pve audit[3760945]: AVC apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-102_</var/lib/lxc>" pid=3760945 comm="apparmor_parser"
Jul 01 11:21:01 pve kernel: audit: type=1400 audit(1688203261.403:47): apparmor="STATUS" operation="profile_load" profile="/usr/bin/lxc-start" name="lxc-102_</var/lib/lxc>" pid=3760945 comm="apparmor_parser"
Jul 01 11:21:01 pve systemd-udevd[3760738]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:21:01 pve systemd-udevd[3760738]: Using default interface naming scheme 'v247'.
Jul 01 11:21:01 pve systemd-udevd[3760738]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:21:01 pve systemd-udevd[3760738]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:21:01 pve systemd-udevd[3760977]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:21:01 pve systemd-udevd[3760977]: Using default interface naming scheme 'v247'.
Jul 01 11:21:01 pve kernel: vmbr1: port 3(fwpr102p0) entered blocking state
Jul 01 11:21:01 pve kernel: vmbr1: port 3(fwpr102p0) entered disabled state
Jul 01 11:21:01 pve kernel: device fwpr102p0 entered promiscuous mode
Jul 01 11:21:01 pve kernel: vmbr1: port 3(fwpr102p0) entered blocking state
Jul 01 11:21:01 pve kernel: vmbr1: port 3(fwpr102p0) entered forwarding state
Jul 01 11:21:01 pve kernel: fwbr102i0: port 1(fwln102i0) entered blocking state
Jul 01 11:21:01 pve kernel: fwbr102i0: port 1(fwln102i0) entered disabled state
Jul 01 11:21:01 pve kernel: device fwln102i0 entered promiscuous mode
Jul 01 11:21:01 pve kernel: fwbr102i0: port 1(fwln102i0) entered blocking state
Jul 01 11:21:01 pve kernel: fwbr102i0: port 1(fwln102i0) entered forwarding state
Jul 01 11:21:01 pve kernel: fwbr102i0: port 2(veth102i0) entered blocking state
Jul 01 11:21:01 pve kernel: fwbr102i0: port 2(veth102i0) entered disabled state
Jul 01 11:21:01 pve kernel: device veth102i0 entered promiscuous mode
Jul 01 11:21:01 pve kernel: eth0: renamed from vethtKcPLb

Code:
Jul 01 11:20:16 pve systemd-udevd[3758882]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:20:16 pve systemd-udevd[3758882]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:20:16 pve systemd-udevd[3758905]: ethtool: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 01 11:20:16 pve systemd-udevd[3758905]: Using default interface naming scheme 'v247'.

Mache ich hier etwas falsch?

Danke für eure Hilfe.

Ronny

P.S. Ich habe jetzt auch den Unifi Controller mal neu gestartet, aber dort eigentlich keine Auffälligkeiten entdeckt.

Virtual Environment 7.4-15
 
Hat jemand eine Idee? Gestern Abend 19.04 Uhr war es wieder soweit. Adguard war bei 100% CPU Auslastung und beim DNS ging nix mehr. :oops:

Danke für eure Hilfe.
 
Kannst du mal die Container Config postern? (cat /etc/pve/lxc/102.conf)
 
Code:
arch: amd64
cores: 1
features: keyctl=1,nesting=1
hostname: Adguard
memory: 1024
nameserver: 10.0.80.1
net0: name=eth0,bridge=vmbr1,firewall=1,gw=10.0.80.1,hwaddr=7E:EE:B5:3A:5D:29,ip=10.0.80.2/24,tag=80,type=veth
onboot: 1
ostype: debian
parent: Update-2023-06-08
rootfs: local-zfs:subvol-102-disk-0,size=4G
searchdomain: 10.0.80.1
startup: order=3
swap: 1024
tags: adguard
unprivileged: 1

[Erstinstallation]
arch: amd64
cores: 1
features: nesting=1
hostname: Adguard
memory: 1024
nameserver: 10.0.80.1
net0: name=eth0,bridge=vmbr1,firewall=1,gw=10.0.80.1,hwaddr=7E:EE:B5:3A:5D:29,ip=10.0.80.2/24,tag=80,type=veth
ostype: debian
rootfs: local-zfs:subvol-102-disk-0,size=4G
searchdomain: 10.0.80.1
snaptime: 1682848972
swap: 1024
tags: adguard
unprivileged: 1

[Update-2023-06-08]
#vor dem Update
arch: amd64
cores: 1
features: keyctl=1,nesting=1
hostname: Adguard
memory: 1024
nameserver: 10.0.80.1
net0: name=eth0,bridge=vmbr1,firewall=1,gw=10.0.80.1,hwaddr=7E:EE:B5:3A:5D:29,ip=10.0.80.2/24,tag=80,type=veth
onboot: 1
ostype: debian
parent: Erstinstallation
rootfs: local-zfs:subvol-102-disk-0,size=4G
searchdomain: 10.0.80.1
snaptime: 1686247015
startup: order=3
swap: 1024
tags: adguard
unprivileged: 1
 
Hmm... du hast da nur 1 Core eingestellt. Ich weiß nicht wie hungrig Adguard ist aber kann es sein das es einfach zu wenig CPU bekommt? Hast du mal versucht 2 cores bereitzustellen?
 
Hallo Philipp,

kann ich machen. Aber die Empfehlung von Adguard Home sagt 1 Core und 512 MB RAM. Im Normalfall bewegt sich die Auslastung bei 1% oder unter 1%.

Ich denke daran liegt es nicht. Die Auslastung steigt irgendwann sprunghaft auf 100% und dann geht nichts mehr. Mehrere Tage läuft es aber normal.

Danke weiterhin für eure Tipps.

Adguard.png
 
hmm... versuch mal wenn es das nächste mal hängt

Code:
journalctl --since=YYYY-MM-DD HH:MM:SS

mit einen Zeitpunkt vor den aufhängen
 
Hallo Philipp,

danke für deinen Tipp ;). Das werde ich tun. Da Adguard, die Windows VM, Home Assistant, RustDesk und die MariaDB über eine 2. LAN Schnittstelle laufen, habe ich diese LAN jetzt im PVE fest auf die 172.16.1.200 eingestellt. Den Haken bei Firewall im Adguard LXC habe ich zusätzlich deaktiviert. VLAN aware ist bei dieser LAN angehakt.

Ich schaue beim nächsten Mal, ob auch erhöhter Traffic auf den Adguard "knallt" und ihn in die Knie zwingt. Was für mich noch ein Rätsel ist, ist, dass Adguard durchgehend läuft, obwohl nicht mehr Netzwerkgeräte vorhanden sind. Die Auslastung liegt immer zwischen 0-2% beim Core und ca. 100 MB RAM.

Ich halte dich/euch auf dem Laufenden. Und nochmals danke für die Unterstützung.

Ronny

P.S. Und natürlich eine wunderschöne und gesunde Woche.
 
Code:
AdGuard Home v0.107.34 Neueste
Diese Version verbessert die Sicherheit von AdGuard Home und behebt einige größere Probleme.

Sicheres Surfen und CPU-Spitzen
Bereits im Juni haben wir ein Sicherheitsupdate für AdGuard Home mit einigen Bugfixes veröffentlicht. Ironischerweise verursachte es einen weiteren Fehler. Safe Browsing und Kindersicherung funktionierten seitdem nicht mehr richtig, was in einigen Fällen zu Leistungseinbußen, zufälligen Abstürzen und enormen CPU-Spitzen führte.

Vielleicht hat sich damit mein Problem erübrigt. Das würde auch erklären, warum der Fehler erst seit ein paar Wochen aufgefallen ist. ;) Ich bleibe hier dran und werde weiter berichten, ob der Fehler damit weg ist.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!