accessing NFS share (Synology) from a Debian 11 VM for use with sonarr/plex/download clients


New Member
May 21, 2023
i want start off by saying that i'm a total newbie in the linux world and its really confusing so far

right now i have my media setup run through docker in Synology NAS and its working well, but i want to move my docker apps from the Synology to Proxmox server VM, and i have been at it for around a week but i find my self going 1 step forward just for the next thing to put me 2 steps backward, its really overwhelming the amount of knowledge and amount of research that i have to do, and i feel so lost, and every comand feels like jargon to me, i tried setting it 1st as an LXC container but decided to go VM route as alot of people were suggesting, then trying to pass through a hardisk to the machine and not knowing how to mount it to the vm even though it shows up in partion tool.

what i have right now is a Proxmox 7.4-3 running debian 11 with docker installed running Sonarr only for now, so i can configure how to connect it to my main library in my
Synology NAS so it can manage my media library, i made an NFS share in my synology of my media share folder and gave access to my Debian VM ip adrress, and then i tried to do

mount -t nfs 192.168.x.x:/volume1/data /mnt -o vers=4.1,noatime,soft

which gives me no error or any response but i guess that it means that it worked,however when i go to try and map sonarr when i go into /mnt its just an empty directory

i even installed KDE plasma and had access to the share through the dolphin file explorer

and it persist even after a shutdown
the user i'm logged into has the UID 1000 and GID 1000 (same PUID and PGID i set for sonarr in docker-compose file)

i'm not sure if its a permission issue or something else i'm totally clueless about.

is my way even the right way to get connect to my NAS storage or is there a better way of connection?
Not sure how to help, got NFS working from my syno, ensure the IP you set in NFS access rights on syno is the correct one (might be NAT somewhere on your network for example...)

I use fstab to mount it it works fine inside my VM :
<ip-of-the-syno>:/volume1/shareA     /mnt/syno/shareA      nfs _netdev,rw,rsize=32768,wsize=32768,soft,intr 0 0

google will help you find nfs commands to list the exported stuff, to be launched from your VM to list what it sees on your NAS.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!