Hi,
I've searched around but couldn't quite find a solution.
So I have a node with two VMs only - Unraid and a Debian with docker and about 25 containers running.
I have noticed with trial and error that my Debian VM will running smoothly if I don't back it up, but when I place it in the backup job, that's configured with snapshot mode, a good portion of the containers will face issues and eventually stop working. Perfect example is Plex, which actually breaks and I then consistently get "Database corrupt".
In fact, one time this even led to having to run fsck to fix filesystem errors within the Debian VM.
Curiously enough, two other VMs in other machines also running docker, but over Ubuntu VMs and don't seem to have any issue (yet those have maybe 4 or 5 containers each).
So the question is, any ideias of other things I should look at/try? Or just accept the fact that I need to run a backup with stop mode just to make sure I have no issues?
Extra info: qemu agent running (regular shutdown and IP showing); backup is done via PBS; backup with snapshot does work, it is the underlying docker which causes issues, maybe because of the freeze operation.
I've searched around but couldn't quite find a solution.
So I have a node with two VMs only - Unraid and a Debian with docker and about 25 containers running.
I have noticed with trial and error that my Debian VM will running smoothly if I don't back it up, but when I place it in the backup job, that's configured with snapshot mode, a good portion of the containers will face issues and eventually stop working. Perfect example is Plex, which actually breaks and I then consistently get "Database corrupt".
In fact, one time this even led to having to run fsck to fix filesystem errors within the Debian VM.
Curiously enough, two other VMs in other machines also running docker, but over Ubuntu VMs and don't seem to have any issue (yet those have maybe 4 or 5 containers each).
So the question is, any ideias of other things I should look at/try? Or just accept the fact that I need to run a backup with stop mode just to make sure I have no issues?
Extra info: qemu agent running (regular shutdown and IP showing); backup is done via PBS; backup with snapshot does work, it is the underlying docker which causes issues, maybe because of the freeze operation.