Zugriff auf Storage nicht möglich

Discussion in 'Proxmox VE (Deutsch)' started by Finity, Jun 14, 2018.

  1. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Hallo zusammen,

    ich habe aktuell das problem das ich in einem Cluster von drei Servern bei zwei nicht auf den storage (vm local, ceph oder nfs) zugreifen kann. Bei dem dritten Server funktioniert es problemlos.

    Lässt sich das Problem durch einen neustart eines Dienstes beheben? Falls ja welcher? Oder muss der ganze Server durchgestartet werden?

    Viele Grüße
     
  2. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Hallo,

    kannst du auch nicht auf das lokale Storage zugreifen?
    Wenn ja wie siehst du das du nicht zugreifen kannst.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Nein auch auf den Lokalen Storage (vm local) kann ich nicht zugreifen.
    Es äußert sich dahingehend das in der gui sobald ich auf den Storage gehe nichts lädt (stuck at loading).Ich kann weder den Content noch ein summary über einen der Storages sehen
     
  4. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Versuch mal den pvestatd zu restarten.

    Code:
    systemctl restart pvestatd
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Leider bringt das keine Abhilfe, folgende Dienste hatte ich bereits neugestartet:
    pvestatd
    corosync
    pve-cluster

    Allerdings fällt auf das en ungewöhnlich lange dauert pvestatd neuzustarten
     
  6. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Ist der NFS server am Host gemounted und ereichbar?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    von der cli aus sind beide nfs shares erreichbar und gemounted
     
  8. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Also "pvesm status" zeigt für alle Storages einen wert an?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    auf den betroffenen Systemen gibt "pvesm status" keine Ausgabe sondern bleibt hängen.
    Auf dem funktionierenden host folgende Ausgabe:

    Code:
    [14:19]root@dev-vh003:~# pvesm status
    Name              Type     Status           Total            Used       Available        %
    backup             nfs   disabled               0               0               0      N/A
    backup-dev         nfs     active      7220203520      5357099008      1564413952   74.20%
    iso                dir     active        19092180         8404000         9695312   44.02%
    local              dir   disabled               0               0               0      N/A
    rbd-pool           rbd     active       373412085       188899573       184512512   50.59%
    vh1-ssd1           lvm   disabled               0               0               0      N/A
    vh2-ssd1           lvm   disabled               0               0               0      N/A
    vh3-sata           lvm     active       975581184       314572800       661008384   32.24%
    vm_local           dir     active        52418560           89888        52328672    0.17%
    
    zur info: vh1 und vh2 haben die Probleme vh3 funktioniert
     
  10. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Schick mal bitte die storage config.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    dir: iso
    path /media/iso
    content iso,vztmpl
    maxfiles 1
    shared 0

    dir: local
    disable
    path /var/lib/vz
    content iso,rootdir,vztmpl,images
    maxfiles 0
    shared 0

    dir: vm_local
    path /media/vm_local
    content images
    maxfiles 1
    shared 0

    nfs: backup
    disable
    export /media/proxmox-backup
    path /mnt/pve/backup
    server 10.XX.XX.230
    content backup
    maxfiles 2
    options vers=3

    lvm: vh3-sata
    vgname sata1
    content images
    nodes dev-vh003
    shared 0

    lvm: vh2-ssd1
    vgname ssd1
    content images
    nodes dev-vh002
    shared 0

    lvm: vh1-ssd1
    vgname ssd1
    content images,rootdir
    nodes dev-vh001
    shared 0

    nfs: backup-dev
    export /media/proxmox-backup/dev
    path /mnt/pve/backup-dev
    server 10.XX.XX.230
    content backup
    maxfiles 2
    options vers=3

    rbd: rbd-pool
    content images,rootdir
    krbd 1
    monhost dev-vh001:6789;dev-vh002:6789;dev-vh003:6789
    nodes dev-vh003,dev-vh001,dev-vh002
    pool rbd-pool
    username admin
     
  12. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Du hast auf dem system das den Output generiert hat das NFS und das local disabled.
    Ich nehme an, das das NFS nicht richtig funktioniert und das den pvestatd zum hängen bringt.

    Wie hast du kontrolliert das das NFS richtig funktioniert?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Indem ich über die cli auf die nfs shares zugreife und bspw. einen Ordner erstelle und wieder lösche.
    Sollte das nfs share nicht richtig eingebunden sein funktioniert das nicht richtig.
     
  14. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Selbst nach einem neustart eines nodes besteht das gleiche Problem das ich auf dem node auf keinen Storage zugreifen kann.

    Auch hängt alles auf dem host, es lässt sich keine VM erstellen (da kein Storage gefunden wird), bestehnde VMs lassen sich nur über die CLI starten ( allein der start dauer 6 minuten). Smätliche gui funktionen reagieren sehr träge.

    Es laufen jedoch alle Dienste, ich weiß gerade nicht wo ich nach dem Fehler suchen kann.
     
    #14 Finity, Jun 15, 2018
    Last edited: Jun 15, 2018
  15. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,870
    Likes Received:
    230
    Also dein Test ist nicht wirklich sicher weil wenn NFS nicht gemountet ist schreibst du eventuell auf das lokale FS.
    Sicher kannst du nur sein wenn mount auch noch sagt das es gemounted ist und du schreiben kannst.

    Hast du dir mal die Syslogs angeschaut?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. Finity

    Finity New Member
    Proxmox VE Subscriber

    Joined:
    May 11, 2017
    Messages:
    18
    Likes Received:
    0
    Ansichtssache ich finde wenn ich auf einem server eine Datei im nfs share erstellen und sie auf einem anderen server sehen und bearbeiten kann ist das schon relativ sicher das der mount richtig funktioniert.

    Im syslog kann ich nichts auffälliges finden. Es gibt keine Fehler und auch sonst sieht er so aus wie auf den funktionierenden systemen

    Edit: Es sieht so aus dass das Problem bei lvm liegt und nicht bei Proxmox. In diesem Zuge scheint es so zu sein das Proxmox nicht auf eine vg zugreifen kann und daher sich aufhängt.
     
    #16 Finity, Jun 15, 2018
    Last edited: Jun 15, 2018
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice