Zugang zum RDP-Server ist fehlgeschlagen od schwarzer Bildschirm

VerticalTechnik

New Member
Sep 26, 2023
10
1
3
Hallo Leute, ich bin Anfänger mit Proxmox und versuche per Remote zu verbinden, aber funktioniert nicht so wie ich will.

Situation und Problem:
- Ich habe ein Proxmox mit 2 VMs (Win10) aufgesetzt.
- Über den WebBroswer kann ich mit der IP auf den Proxmox zugreifen, und auch die VMs starten und nutzen.

Problem:
- Ich möchte aber per Remote direkt auf die VMs zugreifen, dies geht aber nicht.

Remote per RDP
Zugang zum RDP-Server "IP.xxxxxxx" ist fehlgeschlagen.
Das Konto ist eingeschränkt


Remote per VNC-Plugin
Remmina VNC-Plugin für GNOME und KVM
Schwarzer Bildschirm


Hardware:

HP Enterprise - ProLiant MicroServer Gen10
AMD Opteron X3216 (1.6-3.0Ghz)
Dual-Core
8GB-RAM

Installation:
- Maschinentyp = q35 | BIOS = OVMF (UEFI) | SCSI = VirtlO SCSI single
- CPU Typ = host
- ISO = Win10 und virtio-win-latest
- updates ausgeführt
Virtual Win:
- Firewall komplett ausgeschaltet
- Remotedesktop = aktiviert
- Ping an die IP der VM = erfolgreich


Kann mir da jemand vielleicht weiterhelfen?

Beste Grüsse, Tim
 
Last edited:
Windows verbietet default RDP sessions, falls der User kein Kennwort hat. Das kann via secpol.msc geändert bzw. erlaubt werden.

Alternativ über die Registry:

Reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa" /v LimitBlankPasswordUse /t REG_DWORD /d 0 /f
 
Last edited:
  • Like
Reactions: VerticalTechnik
Windows verbietet default RDP sessions, falls der User kein Kennwort hat. Das kann via secpol.msc geändert bzw. erlaubt werden.

Alternativ über die Registry:

Reg add "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa" /v LimitBlankPasswordUse /t REG_DWORD /d 0 /f
Zuerst mal herzlichen Dank für Deine Zeit meinen Thread zu lesen und beantworten.
Tatsächlich habe ich die Win-VM-Users ohne Passwort erstellt.
Ich werde dies entsprechend anpasssen und dann mal schauen ob es mit dem RDP funktioniert.
 
Danke an cwt.. hat tatsächlich geklappt! jetzt muss ich nur noch herausfinden wie ich den Grafiktreiber updaten kann damit ich eine bessere Bildschirmauflösung bekomme.
Derzeit ist die Bildschirmauflösung auf Max. 1280x800, aber ich benötige eine Auflösung auf 3840x2160.
 
  • Like
Reactions: cwt
Ggf. den GPU Typ auf VirtioGPU ändern. Normalerweise sollte das bei RDP aber egal sein. o_O
 
Ggf. den GPU Typ auf VirtioGPU ändern. Normalerweise sollte das bei RDP aber egal sein. o_O
Gibt es eine Anleitung wie man diese Änderung vornimmt?

Ich habe es versucht mit: nano /etc/... amd und/oder opteron hinzugefügt.. nach Reboot wird aber im "IOMMU" nichts in der Hardwareauswahl (Mapped Device) gelistet.
 
Last edited:
VirtIO ist reine Emulation. Du kannst RAM hierfür reservieren/zuteilen, die Grafikberechnung läuft über die CPU. In den Eigenschaften der VM bei „Display“ dieses von „default“ entsprechend umstellen. Die VM muss hierfür einmal heruntergefahren werden, damit die Änderung greift. Nach dem Hochfahren noch die Treiber von der virtio.iso installieren.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!