Zigbee2MQTT Cannot lock port and/or SRSP - SYS error


New Member
Jul 9, 2023
Hi guys,
New to PVE and to this forum.
I've install a zigbee2mqtt container following this guide :

I have a ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2.

My configuration file :

port: 8080 #Change Frontend UI Access Port Default: 8080
homeassistant: true
permit_join: false
base_topic: zigbee2mqtt
server: 'mqtt://'
user: z2m-pve #MQTT Username
password: **z2m-pve** #MQTT Password
keepalive: 60
reject_unauthorized: true
version: 4
#port: /dev/serial/by-id/usb-ITEAD_SONOFF_Zigbee_3.0_USB_Dongle_Plus_V2_20230505151733-if00
#port: /dev/ttyACM0 #Uncomment for USB Port Method
#adapter: deconz (Uncomment For Conbee II)
adapter: ezsp (Uncomment For Sonoff ZBDongle-E)
pan_id: GENERATE
network_key: GENERATE
channel: 20 #Choose Zigbee channel

The dongle is well recognized in PVE and in Zigbee2mqtt

I've already tried :
- a combination of comment / uncomment between USB port method, USB serial method and adapter method.
- checked the permissions
- checked that the dongle is not used elsewhere
- checked that zigbee2mqtt is not already running
- tried to stop, reload, start of zigbee2mqtt.service
- combination of multiple reboots between pve and zigbee2mqtt

And finally, I always either get the Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms) OR the Cannot Lock port error.
It's really strange, I can't say when it's the first error and when it's the second one. It changes from time to time.

I've already searched on many forums and tried what I mentionned above, nothing seems working.

Any clue please?

Thanks a lot,
Works like a charm with Z2M addon in HomeAssistant.

(yes, I've already checked that the dongle is free for use for pve (and its containers), ls -l /dev/serial/by-id is fine, there is no process using it.

Anyone with ideas please guys ?
Exactly the same error message, with the same zigbee device, on a lxc container created with the same tteck script.

The error msg on my side is different if the device is connected, or if it is not. So usb mapping is somehow working but probably with missing rights somewhere?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!