ZFS Raid array eats alot of space


New Member
Aug 14, 2023
I have a strange problem where RaidZ(1) takes away alot of space.
I tried setting up Raid array with mdadm and I found out that its not supported. So I tried seeting it up from 3x4TB disks. In Proxmox WebUI it shows as 12TB space. So if I set it to RaidZ it should be 7.9TB as its shofn under node Storage... so far everything looking good. But when I try to add disk to VM (Ubuntu server) I can only arrange 5350TiB and disk is shown as full. When I check space on server it only show up as 5.3TB space.

there should be at least 7.5TB, or am I wrong?
Server is running as media centre, and disk space is important to, but I still want to have redundancy.

MB: MSI B350
CPU: Pyzen5 2400g
RAM: 16gb
SSD: Nvme Samsung 860 250gb
HDD: 3x Seagate Ironwolf 4TB


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!