Wrong zpool version


Active Member
Apr 16, 2019
I have a quite weird problem here... I was running PVE 6 and decided to upgrade to 7, and then, if everything would be ok, to 8. Sounded like a plan.
Before starting, I was checking things, and the first thing that was wrong, was that zpool command complained about /etc/init.d/zfs-fuse service being dead, and I restarted it. The zfs pool was in use and worked without problem before and after the restart of this service. Not sure when it stoped... When I tried to run zpool status again, I got this error:
# zpool status
  pool: vmdata
 state: UNAVAIL
status: The pool has been upgraded to a newer, incompatible on-disk version.
    The pool cannot be accessed on this system.
action: Access the pool from a system running more recent software, or
    restore the pool from backup.
   see: http://www.sun.com/msg/ZFS-8000-A5
 scrub: none requested
And as I did some updates not long ago, I was thinking I should try upgrade de zpool:
# zpool upgrade
This system is currently running ZFS pool version 23.

The following pools are formatted using a newer software version and
cannot be accessed on the current system.

---  ------------
5000   vmdata

Use 'zpool upgrade -v' for a list of available versions and their associated
Weird... then I tried the suggested command:
# zpool upgrade -v
This system is currently running ZFS pool version 23.

The following versions are supported:

---  --------------------------------------------------------
 1   Initial ZFS version
 2   Ditto blocks (replicated metadata)
 3   Hot spares and double parity RAID-Z
 4   zpool history
 5   Compression using the gzip algorithm
 6   bootfs pool property
 7   Separate intent log devices
 8   Delegated administration
 9   refquota and refreservation properties
 10  Cache devices
 11  Improved scrub performance
 12  Snapshot properties
 13  snapused property
 14  passthrough-x aclinherit
 15  user/group space accounting
 16  stmf property support
 17  Triple-parity RAID-Z
 18  Snapshot user holds
 19  Log device removal
 20  Compression using zle (zero-length encoding)
 21  Deduplication
 22  Received properties
 23  Slim ZIL

For more information on a particular version, including supported releases, see:


Where 'N' is the version number.
What? So my pool is 5000 and I know for sure that was what I used, but the zfs drivers now tell me it only knows version 23... Also, my drives are absolutely fine...
So I decided to upgrade PVE to 7, in a hope that this will fix it, and now I'm on latest 7.4-16, but my zfs pool is still unaccessible. I see a folder named zfs-kstat in the root of my system, which I don't remember seeing it before and is not prezent on any of my other PVE servers.

Anyone have any ideea what's going on and how to fix this? How to get back version 5000 running?
Last edited:
Well... somehow looks like I was missing zfsutils-linux and zfs-zed packages... Installing them fixed the problem (removing that zfs-fuse service too). Of course, I had to import the pool, but all went fine...
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!