Windows guest VM with cloudbase init

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
551
48
33
I'll take a look.
 

p.lakis

New Member
Jul 11, 2018
23
0
1
33
Anyone get Server 2019 working?
I can pass the config to the drive but the config doesnt work, Had success with Win 10 + Server 16.
 

webjin

New Member
Aug 30, 2019
3
0
1
31
I tried to experiment on windows2008R2 but it was not successful. Is it not supported?
 

mira

Proxmox Staff Member
Staff member
Aug 1, 2018
551
48
33
Any errors in the cloudbase-init.log?
 
Jul 31, 2018
98
9
13
58
yes I know about I use winrm to do that after its running
BTW I just upgarded my lab to Proxmox V6 and the cloud init works ( not sure about the password
OI assume the same issure though as windows needs a clear text password )

but no patches are needed so very cool
 
  • Like
Reactions: eranj

rnmkr

New Member
Mar 10, 2019
11
1
3
26
yes I know about I use winrm to do that after its running
BTW I just upgarded my lab to Proxmox V6 and the cloud init works ( not sure about the password
OI assume the same issure though as windows needs a clear text password )

but no patches are needed so very cool
Hi where can I download Windows image?
 

xiabin

New Member
Jun 8, 2018
3
2
3
24
Hello,Has anyone made cloudbase-init work in proxmox ve 6.0? I tried for a long time but all failed....I'm very frustrated because I don't seem to see hope for a patch yet......
 

eranj

Member
Aug 6, 2013
4
0
21
BTW I just upgarded my lab to Proxmox V6 and the cloud init works ( not sure about the password
OI assume the same issure though as windows needs a clear text password )
You are right.
It doesn't set the password because of the encryption.
Too bad Proxmox doesn't fix this already.
Maybe you can release a patch for Proxmox 6.x meanwhile.
This will be appreciated.
 

eranj

Member
Aug 6, 2013
4
0
21
Hello,Has anyone made cloudbase-init work in proxmox ve 6.0? I tried for a long time but all failed....I'm very frustrated because I don't seem to see hope for a patch yet......
For now, the password could not be set.
At least not in an easy way.
 

NessageHostsINC

New Member
Aug 19, 2019
25
2
3
Dear fellow users,

I have made my own Windows Server 2019 image on Proxmox 6.1-7 however the only present issue is the automated setting of DNS domain.

Please bear in mind I am not trying to set automatic passwords due to the reasoning that it has been mentioned that it does not work previously in this conversation.

How may I get Cloudbase init to set the DNS domain or specify defaults for Windows?

My kindest regards
 

NeuraFTW

New Member
May 19, 2020
3
0
1
18
Did anyone fix "Cannot set the password in the metadata as it is not supported by this service"
I'm still getting it even though it's clearly a plaintext password, I can see it in the config drive
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!