Windows 10 VM with GPU Passthrough Chugging after Upgrade to Proxmox 7.0

ikogan

Active Member
Apr 8, 2017
29
1
28
38
For the past few years I've been gaming on a Windows 10 VM with a GTX 1070 Ti. This has been working surprisingly well. After upgrading to Proxmox 7.0, the VM is now chugging seemingly randomly. I can play for an hour or two fine but then suddenly, I'll start getting "skips" for about half second to a second every few seconds. Latency measurements pinging the VM show that the response time increases from an average <1ms to over 1 second during these "blips". Here are the vm settings:

Code:
agent: 1
balloon: 0
bios: ovmf
boot: order=scsi0;scsi2
cores: 6
cpu: host,flags=+pcid;+spec-ctrl
efidisk0: local-lvm:vm-111-disk-0,size=128K
hostpci0: 01:00,pcie=1,x-vga=on
hotplug: disk,network,usb
machine: pc-q35-3.1
memory: 24576
name: Arcade
net0: virtio=52:99:B7:8A:56:48,bridge=vmbr0,tag=20
numa: 1
ostype: win10
scsi0: /dev/disk/by-id/nvme-Samsung_SSD_970_EVO_500GB_S466NX0K905003J,backup=0,discard=on,iothread=1,replicate=0,size=488386584K,ssd=1
scsi2: none,media=cdrom
scsihw: virtio-scsi-single
smbios1: uuid=e66003de-70c4-4e20-8795-774f6af54c84
sockets: 1
vga: none
vmgenid: f60ff0d9-2272-49fd-8288-fc11969a3883

The host is booted with the following command line:

Code:
BOOT_IMAGE=/boot/vmlinuz-5.11.22-4-pve root=/dev/mapper/pve-root ro quiet rootdelay=10 intel_iommu=on

Kernel module configs:

Code:
bluetooth.conf:
----------------
blacklist bluetooth
blacklist btrtl
blacklist btintel
blacklist btbcm
blacklist btusb

i915.conf:
----------------
options i915 enable_gvt=1

kvm-intel.conf:
----------------
options kvm-intel nested=Y

mdadm.conf:
----------------
# mdadm module configuration file
# set start_ro=1 to make newly assembled arrays read-only initially,
# to prevent metadata writes.  This is needed in order to allow
# resume-from-disk to work - new boot should not perform writes
# because it will be done behind the back of the system being
# resumed.  See http://bugs.debian.org/415441 for details.

options md_mod start_ro=1

pve-blacklist.conf:
----------------
# This file contains a list of modules which are not supported by Proxmox VE

# nidiafb see bugreport https://bugzilla.proxmox.com/show_bug.cgi?id=701
blacklist nvidiafb

vfio.conf:
----------------
options vfio-pci ids=10de:1b82,10de:10f0 disable_vga=1
options kvm ignore_msrs=1

blacklist radeon
blacklist nouveau
blacklist nvidia

So far I've tried every machine version of q35 from 6.0 to 4.0 as well as 3.1. I've tried this with both GameStream using Moonlight and Steam Streaming. The chugging can also be felt when just using VNC. To add to this, this machine is running 4 Ceph OSDs one other LXC container and another VM. Memory is sitting at 55.5G/62.7G and CPU on the host is at about 50-65% of each core (of the 8). The chugging happens whether I'm in a game or on the desktop. What can I do to figure out what's causing this? Is it possible the I/O from Ceph is saturating a bus? The only disk on the VM is an nvme disk that's also passed through.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!