[SOLVED] Win10: Umstellung von ide auf virtio macht Probleme

Dec 19, 2012
481
14
83
Hallo.
Ich habe einen Win10 Server als KVM laufen. Die HDD wurde leider bei der Installation als ide0 eingebunden, was aber zu wenig Performance liefert. Nun wollte ich das auf virtIo/scsci umstellen, doch dann bootet die VM nicht mehr.
Ich lande auf einem BlueScreen mit der Meldung "inaccessible boot device" -- die Treiber werden also offenbar nicht verwendet?

Hier die .conf der VM:
agent: 1
bios: ovmf
boot: cdn
bootdisk: scsi0
cores: 6
ide1: none,media=cdrom
keyboard: de
memory: 10240
name: W10Server
net0: virtio=4E:E4:7F:3A:C1:49,bridge=vmbr1
numa: 0
onboot: 1
ostype: win10
scsi0: RAID10-local:300/vm-300-disk-0.qcow2,cache=writethrough,discard=on,size=127G
scsihw: virtio-scsi-pci
smbios1: uuid=da91bba4-4a0e-4a78-8132
sockets: 1
startup: order=8
tablet: 0
vga: qxl

Gefolgt bin ich dieser Anleitung:
https://pve.proxmox.com/wiki/Paravirtualized_Block_Drivers_for_Windows#Setup_On_Running_Windows
Das hat auch alles funktioniert -- bis auf der Tatsache, dass im Festplattenmanager die Meldung erschien:

"Datenträger ist aufgrund einer von einem Administrator festgelegten Richtlinie offline"

Daher die Frage: Was fehlt bzw wie geht man (in Kombination mit UEFI) vor, damit das System auch mit VirtIO-Treibern bootet?
Danke!
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!