Which log to tail ?

ozgurerdogan

Renowned Member
May 2, 2010
605
5
83
Bursa, Turkey, Turkey
My proxmox lately hangs or loose connections and I have to reset node to become online. But I can not see any failure in logs. Actually not sure which log to look at. Can you please guide ? I look at all logs files but can not see anything.
 
If the Disks cant write anything at this moment, you can't find it in the logs.

You can use kernel dump to check what's going on. But afaik there might be some problems with using it in combination with PVE.

Do you already checked your hardware? You only lost network?
 
Server is located at hetzner and they say it will take around 14 hours to check hardware which is too long for me. I loose all connection to server ssh, ping etc. and I send a hardware reset from panel and it becomes online again.

Only things I found in logs are; but in two months, this happened three time only.


Code:
Jun  2 12:15:33 hs1 kernel: [4508657.319058] e1000e 0000:00:1f.6 enp0s31f6: Detected Hardware Unit Hang:
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   TDH                  <0>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   TDT                  <4>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   next_to_use          <4>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   next_to_clean        <0>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] buffer_info[next_to_clean]:
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   time_stamp           <1432df892>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   next_to_watch        <0>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   jiffies              <1432e0238>
Jun  2 12:15:33 hs1 kernel: [4508657.319058]   next_to_watch.status <0>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] MAC Status             <80083>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] PHY Status             <796d>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] PHY 1000BASE-T Status  <3800>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] PHY Extended Status    <3000>
Jun  2 12:15:33 hs1 kernel: [4508657.319058] PCI Status             <10>
Jun  2 12:15:33 hs1 kernel: [4508657.350813] e1000e 0000:00:1f.6 enp0s31f6: Reset adapter unexpectedly
 
Is the NIC onboard or AIC? Do you have a second LAN port? If yes, can you change the cable to the other port?
 
hi,

can you mark this thread [SOLVED] if the workaround in the link solves your issue? (you need to advanced edit your first post)
 
edit your first post with advanced edit or find thread tools
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!